lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 27 Dec 2012 21:49:37 -0200
From:	Mauro Carvalho Chehab <mchehab@...hat.com>
To:	Ezequiel Garcia <elezegarcia@...il.com>
Cc:	linux-kernel@...r.kernel.org, linux-media@...r.kernel.org,
	Julia.Lawall@...6.fr, kernel-janitors@...r.kernel.org,
	Laurent Pinchart <laurent.pinchart@...asonboard.com>,
	Peter Senna Tschudin <peter.senna@...il.com>
Subject: Re: [PATCH 01/23] uvc: Replace memcpy with struct assignment

Em Thu, 27 Dec 2012 18:12:46 -0300
Ezequiel Garcia <elezegarcia@...il.com> escreveu:

> Mauro,
> 
> On Tue, Oct 23, 2012 at 4:57 PM, Ezequiel Garcia <elezegarcia@...il.com> wrote:
> > This kind of memcpy() is error-prone. Its replacement with a struct
> > assignment is prefered because it's type-safe and much easier to read.
> >
> > Found by coccinelle. Hand patched and reviewed.
> > Tested by compilation only.
> >
> > A simplified version of the semantic match that finds this problem is as
> > follows: (http://coccinelle.lip6.fr/)
> >
> > // <smpl>
> > @@
> > identifier struct_name;
> > struct struct_name to;
> > struct struct_name from;
> > expression E;
> > @@
> > -memcpy(&(to), &(from), E);
> > +to = from;
> > // </smpl>
> >
> > Cc: Laurent Pinchart <laurent.pinchart@...asonboard.com>
> > Signed-off-by: Peter Senna Tschudin <peter.senna@...il.com>
> > Signed-off-by: Ezequiel Garcia <elezegarcia@...il.com>
> > ---
> >  drivers/media/usb/uvc/uvc_v4l2.c |    6 +++---
> >  1 files changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/drivers/media/usb/uvc/uvc_v4l2.c b/drivers/media/usb/uvc/uvc_v4l2.c
> > index f00db30..4fc8737 100644
> > --- a/drivers/media/usb/uvc/uvc_v4l2.c
> > +++ b/drivers/media/usb/uvc/uvc_v4l2.c
> > @@ -314,7 +314,7 @@ static int uvc_v4l2_set_format(struct uvc_streaming *stream,
> >                 goto done;
> >         }
> >
> > -       memcpy(&stream->ctrl, &probe, sizeof probe);
> > +       stream->ctrl = probe;
> >         stream->cur_format = format;
> >         stream->cur_frame = frame;
> >
> > @@ -386,7 +386,7 @@ static int uvc_v4l2_set_streamparm(struct uvc_streaming *stream,
> >                 return -EBUSY;
> >         }
> >
> > -       memcpy(&probe, &stream->ctrl, sizeof probe);
> > +       probe = stream->ctrl;
> >         probe.dwFrameInterval =
> >                 uvc_try_frame_interval(stream->cur_frame, interval);
> >
> > @@ -397,7 +397,7 @@ static int uvc_v4l2_set_streamparm(struct uvc_streaming *stream,
> >                 return ret;
> >         }
> >
> > -       memcpy(&stream->ctrl, &probe, sizeof probe);
> > +       stream->ctrl = probe;
> >         mutex_unlock(&stream->mutex);
> >
> >         /* Return the actual frame period. */
> > --
> > 1.7.4.4
> >
> 
> It seems you've marked this one as "Changes requested" [1].
> However, Laurent didn't request any change,
> but just pointed out we missed one memcpy replacement candidate.
> 
> I believe it's safe to apply the patch (together with the other 20 patches)
> and we can fix the missing spot in another patch.

The other patches got applied already. Well just do whatever Laurent asked you
and re-submit this one ;)

Regards,
Mauro
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ