lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Tue, 22 Jan 2013 21:52:56 +0200
From:	Pekka Enberg <penberg@...nel.org>
To:	Cong Ding <dinggnu@...il.com>
Cc:	Gleb Natapov <gleb@...hat.com>,
	Sasha Levin <levinsasha928@...il.com>,
	Asias He <asias.hejun@...il.com>, kvm@...r.kernel.org,
	linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2] kvm tools: remove redundant "if" condition

On Sat, Jan 19, 2013 at 12:27 PM, Cong Ding <dinggnu@...il.com> wrote:
> On Sat, Jan 19, 2013 at 10:58:33AM +0200, Pekka Enberg wrote:
>> On Wed, Jan 16, 2013 at 6:52 PM, Cong Ding <dinggnu@...il.com> wrote:
>> > After we check (state.kcount != 0), state.kcount has to be 0 in all the "else"
>> > branchs.
>> >
>> > Signed-off-by: Cong Ding <dinggnu@...il.com>
>> > ---
>> >  tools/kvm/hw/i8042.c |    2 +-
>> >  1 file changed, 1 insertion(+), 1 deletion(-)
>> >
>> > diff --git a/tools/kvm/hw/i8042.c b/tools/kvm/hw/i8042.c
>> > index 9f8be6a..9035732 100644
>> > --- a/tools/kvm/hw/i8042.c
>> > +++ b/tools/kvm/hw/i8042.c
>> > @@ -189,7 +189,7 @@ static u32 kbd_read_data(void)
>> >                 state.mcount--;
>> >                 kvm__irq_line(state.kvm, AUX_IRQ, 0);
>> >                 kbd_update_irq();
>> > -       } else if (state.kcount == 0) {
>> > +       } else {
>> >                 i = state.kread - 1;
>> >                 if (i < 0)
>> >                         i = QUEUE_SIZE;
>>
>> This doesn't look right. The 'kcount' field is an int so the value can
>> be negative.
> But the former check is "state.kcount != 0" as I described in the commit
> message. Notice the difference between variable names in the "if" condition: the
> first one is kcount, the second one is mcount, and the third one is same as the
> first one kcount.
>
> Ok, the original code is
>         if (state.kcount != 0) {
>                 /* do something when (state.kcount != 0) */
>         } else if (state.mcount > 0) {
>                 /* do something when (state.kcount == 0 && state.mount > 0) */
>         } else if (state.kcount == 0) {
>                 /* do something when (state.kcount == 0 && state.mount <= 0) */
>         }
> For the third branch, it runs when state.kcount == 0 and state.mount <= 0,
> it's not necessary to ensure state.kcount == 0 again.

Right you are. Applied, thanks!
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ