[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-id: <51009F6D.5040001@samsung.com>
Date: Thu, 24 Jan 2013 11:41:49 +0900
From: Jaehoon Chung <jh80.chung@...sung.com>
To: Dongjin Kim <tobetter@...il.com>
Cc: "unlisted-recipients: ;Chris Ball" <cjb@...top.org>,
Arnd Bergmann <arnd@...db.de>,
Thomas Abraham <thomas.abraham@...aro.org>,
Will Newton <will.newton@...tec.com>,
linux-mmc@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] mmc: dw_mmc: Add MSHC compatible for Exynos4412
On 01/24/2013 12:24 AM, Dongjin Kim wrote:
> This patch adds the compatible string for MSHC controller of Exynos4412, and
> reuse the controller specific properties with Exynos5250 since those have same
> features.
>
> Signed-off-by: Dongjin Kim <tobetter@...il.com>
> ---
> drivers/mmc/host/dw_mmc-exynos.c | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/drivers/mmc/host/dw_mmc-exynos.c b/drivers/mmc/host/dw_mmc-exynos.c
> index 0cb9bcb..4f7685f 100644
> --- a/drivers/mmc/host/dw_mmc-exynos.c
> +++ b/drivers/mmc/host/dw_mmc-exynos.c
> @@ -204,6 +204,8 @@ static const struct dw_mci_drv_data exynos5250_drv_data = {
> };
>
> static const struct of_device_id dw_mci_exynos_match[] = {
> + { .compatible = "samsung,exynos4412-dw-mshc",
> + .data = &exynos5250_drv_data, },
If we can use the same drv_data, should be changed to more generic name, not "exynos5250_".
Best Regards,
Jaehoon Chung
> { .compatible = "samsung,exynos5250-dw-mshc",
> .data = &exynos5250_drv_data, },
> {},
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists