[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20130204194942.GZ27963@mtj.dyndns.org>
Date: Mon, 4 Feb 2013 11:49:42 -0800
From: Tejun Heo <tj@...nel.org>
To: Lai Jiangshan <laijs@...fujitsu.com>
Cc: linux-kernel@...r.kernel.org
Subject: Re: [PATCH 01/13] workqueue: remove WORK_CPU_NONE
Hello, Lai.
On Fri, Feb 01, 2013 at 02:41:24AM +0800, Lai Jiangshan wrote:
> In __next_wq_cpu() for_each_*wq_cpu(), the name WORK_CPU_LAST
> is proper than WORK_CPU_NONE, convert them to WORK_CPU_LAST.
>
> WORK_CPU_NONE is not used any more, just remove it.
...
> #define for_each_wq_cpu(cpu) \
> for ((cpu) = __next_wq_cpu(-1, cpu_possible_mask, 3); \
> - (cpu) < WORK_CPU_NONE; \
> + (cpu) < WORK_CPU_LAST; \
> (cpu) = __next_wq_cpu((cpu), cpu_possible_mask, 3))
LAST implies that it's the last element of the range and thus that
it's an inclusive range. Maybe we should rename it to WORK_CPU_END?
Thanks.
--
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists