[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20130204230209.GK14246@lenny.home.zabbo.net>
Date: Mon, 4 Feb 2013 15:02:09 -0800
From: Zach Brown <zab@...hat.com>
To: Jeff Moyer <jmoyer@...hat.com>
Cc: Lin Feng <linfeng@...fujitsu.com>, akpm@...ux-foundation.org,
mgorman@...e.de, bcrl@...ck.org, viro@...iv.linux.org.uk,
khlebnikov@...nvz.org, walken@...gle.com,
kamezawa.hiroyu@...fujitsu.com, minchan@...nel.org,
riel@...hat.com, rientjes@...gle.com,
isimatu.yasuaki@...fujitsu.com, wency@...fujitsu.com,
laijs@...fujitsu.com, jiang.liu@...wei.com, linux-mm@...ck.org,
linux-aio@...ck.org, linux-fsdevel@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/2] fs/aio.c: use get_user_pages_non_movable() to pin
ring pages when support memory hotremove
> > index 71f613c..0e9b30a 100644
> > --- a/fs/aio.c
> > +++ b/fs/aio.c
> > @@ -138,9 +138,15 @@ static int aio_setup_ring(struct kioctx *ctx)
> > }
> >
> > dprintk("mmap address: 0x%08lx\n", info->mmap_base);
> > +#ifdef CONFIG_MEMORY_HOTREMOVE
> > + info->nr_pages = get_user_pages_non_movable(current, ctx->mm,
> > + info->mmap_base, nr_pages,
> > + 1, 0, info->ring_pages, NULL);
> > +#else
> > info->nr_pages = get_user_pages(current, ctx->mm,
> > info->mmap_base, nr_pages,
> > 1, 0, info->ring_pages, NULL);
> > +#endif
>
> Can't you hide this in your 1/1 patch, by providing this function as
> just a static inline wrapper around get_user_pages when
> CONFIG_MEMORY_HOTREMOVE is not enabled?
Yes, please. Having callers duplicate the call site for a single
optional boolean input is unacceptable.
But do we want another input argument as a name? Should aio have been
using get_user_pages_fast()? (and so now _fast_non_movable?)
I wonder if it's time to offer the booleans as a _flags() variant, much
like the current internal flags for __get_user_pages(). The write and
force arguments are already booleans, we have a different fast api, and
now we're adding non-movable. The NON_MOVABLE flag would be 0 without
MEMORY_HOTREMOVE, easy peasy.
Turning current callers' mysterious '1, 1' in to 'WRITE|FORCE' might
also be nice :).
No?
- z
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists