[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20130212162222.e4103ddb.akpm@linux-foundation.org>
Date: Tue, 12 Feb 2013 16:22:22 -0800
From: Andrew Morton <akpm@...ux-foundation.org>
To: Tony Luck <tony.luck@...il.com>
Cc: Xishi Qiu <qiuxishi@...wei.com>,
Matt Fleming <matt.fleming@...el.com>, fenghua.yu@...el.com,
Liujiang <jiang.liu@...wei.com>, linux-ia64@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-efi@...r.kernel.org,
linux-mm@...ck.org, Hanjun Guo <guohanjun@...wei.com>,
WuJianguo <wujianguo@...wei.com>
Subject: Re: [PATCH V3] ia64/mm: fix a bad_page bug when crash kernel
booting
On Tue, 12 Feb 2013 16:11:33 -0800
Tony Luck <tony.luck@...il.com> wrote:
> Building linux-next today (tag next-20130212) I get the following errors when
> building arch/ia64/configs/{tiger_defconfig, zx1_defconfig, bigsur_defconfig,
> sim_defconfig}
>
> arch/ia64/mm/init.c: In function 'free_initrd_mem':
> arch/ia64/mm/init.c:215: error: 'max_addr' undeclared (first use in
> this function)
> arch/ia64/mm/init.c:215: error: (Each undeclared identifier is
> reported only once
> arch/ia64/mm/init.c:215: error: for each function it appears in.)
> arch/ia64/mm/init.c:216: error: implicit declaration of function
> 'GRANULEROUNDDOWN'
>
`max_addr' is an awesomely bad name for a global identifier, btw.
And this:
-static u64 mem_limit = ~0UL, max_addr = ~0UL, min_addr = 0UL;
+u64 mem_limit = ~0UL, max_addr = ~0UL, min_addr = 0UL;
needlessly exported `mem_limit' and `min_addr' as well. These too are
very poor global identifiers.
Also, Matt suggested an alternative implementation which afaik hasn't
been responded to.
I think I'll just drop the patch.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists