[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <84A937D219C2B44EB8EA44831ACA1E49171E5145@PRN-MBX02-3.TheFacebook.com>
Date: Tue, 5 Mar 2013 22:20:07 +0000
From: Dan Williams <djbw@...com>
To: Dave Jiang <dave.jiang@...el.com>
CC: "vinod.koul@...el.com" <vinod.koul@...el.com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] ioatdma: make debug output more readable
On 3/4/13 9:59 AM, "Dave Jiang" <dave.jiang@...el.com> wrote:
>Making OP field a hex instead of integer to make it more readable. Also
>add
>the dump out of the NEXT field.
>
>Signed-off-by: Dave Jiang <dave.jiang@...el.com>
>---
> drivers/dma/ioat/dma.h | 2 +-
> drivers/dma/ioat/dma_v3.c | 3 ++-
> 2 files changed, 3 insertions(+), 2 deletions(-)
>
>diff --git a/drivers/dma/ioat/dma.h b/drivers/dma/ioat/dma.h
>index 53a4cbb..95ae7b3 100644
>--- a/drivers/dma/ioat/dma.h
>+++ b/drivers/dma/ioat/dma.h
>@@ -179,7 +179,7 @@ __dump_desc_dbg(struct ioat_chan_common *chan, struct
>ioat_dma_descriptor *hw,
> struct device *dev = to_dev(chan);
>
> dev_dbg(dev, "desc[%d]: (%#llx->%#llx) cookie: %d flags: %#x"
>- " ctl: %#x (op: %d int_en: %d compl: %d)\n", id,
>+ " ctl: %#10.8x (op: %#x int_en: %d compl: %d)\n", id,
> (unsigned long long) tx->phys,
> (unsigned long long) hw->next, tx->cookie, tx->flags,
> hw->ctl, hw->ctl_f.op, hw->ctl_f.int_en, hw->ctl_f.compl_write);
>diff --git a/drivers/dma/ioat/dma_v3.c b/drivers/dma/ioat/dma_v3.c
>index 53ea4bd..ce6fcee 100644
>--- a/drivers/dma/ioat/dma_v3.c
>+++ b/drivers/dma/ioat/dma_v3.c
>@@ -605,7 +605,7 @@ dump_pq_desc_dbg(struct ioat2_dma_chan *ioat, struct
>ioat_ring_ent *desc, struct
> int i;
>
> dev_dbg(dev, "desc[%d]: (%#llx->%#llx) flags: %#x"
>- " sz: %#x ctl: %#x (op: %d int: %d compl: %d pq: '%s%s' src_cnt:
>%d)\n",
>+ " sz: %#10.8x ctl: %#x (op: %#x int: %d compl: %d pq: '%s%s' src_cnt:
>%d)\n",
> desc_id(desc), (unsigned long long) desc->txd.phys,
> (unsigned long long) (pq_ex ? pq_ex->next : pq->next),
> desc->txd.flags, pq->size, pq->ctl, pq->ctl_f.op, pq->ctl_f.int_en,
>@@ -617,6 +617,7 @@ dump_pq_desc_dbg(struct ioat2_dma_chan *ioat, struct
>ioat_ring_ent *desc, struct
> (unsigned long long) pq_get_src(descs, i), pq->coef[i]);
> dev_dbg(dev, "\tP: %#llx\n", pq->p_addr);
> dev_dbg(dev, "\tQ: %#llx\n", pq->q_addr);
>+ dev_dbg(dev, "\tNEXT: %#llx\n", pq->next);
Looks ok, did you want to distinguish when ->next is pointing to an
extended descriptor?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists