[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAK5ve-+XCqrp8gkh4FE0Up0y+jDU7knowG1kXjpaf1+zuAhYhg@mail.gmail.com>
Date: Wed, 13 Mar 2013 16:19:09 -0700
From: Bryan Wu <cooloney@...il.com>
To: "Kim, Milo" <Milo.Kim@...com>
Cc: "linux-leds@...r.kernel.org" <linux-leds@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"Jeong, Daniel" <Daniel.Jeong@...com>
Subject: Re: [PATCH 2/3] leds: add LED Trigger for camera function
On Wed, Mar 13, 2013 at 4:16 PM, Kim, Milo <Milo.Kim@...com> wrote:
>> > +#if defined(CONFIG_LEDS_TRIGGER_CAMERA) ||
>> defined(CONFIG_LEDS_TRIGGER_CAMERA_MODULE)
>> > +extern void ledtrig_flash_ctrl(bool on);
>> > +extern void ledtrig_torch_ctrl(bool on);
>> > +#else
>> > +#define ledtrig_flash_ctrl(x) do {} while(0)
>> > +#define ledtrig_torch_ctrl(x) do {} while(0)
>>
>> It's better don't use #define macros but use real empty functions like
>> this:
>> static inline void ledtrig_flash_ctrl(bool on)
>> {
>> return;
>> }
>
> I agree, but other trigger functions are declared as do-while definition.
> So I would let them unify if it's not critical.
> I'd like to have your opinion, which is better.
>
> Thanks,
> Milo
I did same thing before, Andrew Morton corrected me like this. Please
feel free to submit patch to move other macros to empty functions.
Thanks,
-Bryan
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists