[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1365004839-21982-1-git-send-email-anton@redhat.com>
Date: Wed, 3 Apr 2013 18:00:30 +0200
From: Anton Arapov <anton@...hat.com>
To: Anton Arapov <anton@...hat.com>, Oleg Nesterov <oleg@...hat.com>,
Srikar Dronamraju <srikar@...ux.vnet.ibm.com>
Cc: LKML <linux-kernel@...r.kernel.org>,
Josh Stone <jistone@...hat.com>,
Frank Eigler <fche@...hat.com>,
Peter Zijlstra <peterz@...radead.org>,
Ingo Molnar <mingo@...e.hu>,
Ananth N Mavinakayanahalli <ananth@...ibm.com>,
adrian.m.negreanu@...el.com, Torsten.Polle@....de
Subject: [PATCH v1 0/9] uretprobes: Return uprobes implementation
Hello All!
Uretprobes' core implementation. Enables a function's return probes in uprobe-
based event tracing.
Patchset introduce additional handler (ret_handler) in uprobe consumer that
defines uretprobe.
There is a regular uprobe with return probe handler behind every uretprobe.
Once hit the uprobe that has ret_handler set, we hijack the return address of
the probed function and replace it with the address of trampoline. Trampoline
is a preallocated page in probed task's xol area that filled with breakpoint
opcode. In turn, when the return breakpoint is hit, we invoke the ret_handler.
The patchset shouldn't be difficult to read and hopefully the comments to
commits will help. Please, review.
patchset in git:
http://github.com/arapov/linux-aa/commits/uretprobes_v1
previous versions:
v0: https://lkml.org/lkml/2013/3/22/218
RFC reviews:
RFCv4: https://lkml.org/lkml/2013/3/4/246
RFCv3: https://lkml.org/lkml/2013/2/28/148
RFCv2: https://lkml.org/lkml/2013/1/9/157
RFCv1: https://lkml.org/lkml/2012/12/21/133
thanks,
Anton.
Anton Arapov (9):
uretprobes: Introduce uprobe_consumer->ret_handler()
uretprobes: Reserve the first slot in xol_vma for trampoline
uretprobes/x86: Hijack return address
uretprobes/ppc: Hijack return address
uretprobes: Return probe entry, prepare_uretprobe()
uretprobes: Return probe exit, invoke handlers
uretprobes: Limit the depth of return probe nestedness
uretprobes: Remove -ENOSYS as return probes implemented
uretprobes: Documentation update
Documentation/trace/uprobetracer.txt | 126 +++++++++++++---------
arch/powerpc/include/asm/uprobes.h | 1 +
arch/powerpc/kernel/uprobes.c | 13 +++
arch/x86/include/asm/uprobes.h | 1 +
arch/x86/kernel/uprobes.c | 29 +++++
include/linux/uprobes.h | 7 ++
kernel/events/uprobes.c | 202 +++++++++++++++++++++++++++++++++--
7 files changed, 320 insertions(+), 59 deletions(-)
--
1.8.1.4
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists