[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <5166D468.4030109@intel.com>
Date: Thu, 11 Apr 2013 16:19:04 +0100
From: Matt Fleming <matt.fleming@...el.com>
To: Richard Weinberger <richard@....at>
CC: cbouatmailru@...il.com, ccross@...roid.com, keescook@...omium.org,
tony.luck@...el.com, linux-efi@...r.kernel.org,
linux-kernel@...r.kernel.org, matthew.garrett@...ula.com
Subject: Re: [PATCH 2/2] x86,efi: Implement no_storage_paranoia parameter
On 10/04/13 09:59, Richard Weinberger wrote:
> Using this parameter one can disable the storage_size/2 check if
> he is really sure that the UEFI does sane gc and fulfills the spec.
>
> This parameter is useful if a devices uses more than 50% of the
> storage by default.
> The Intel DQSW67 desktop board is such an sucker for exmaple.
>
> Signed-off-by: Richard Weinberger <richard@....at>
> ---
> arch/x86/platform/efi/efi.c | 13 ++++++++++++-
> 1 file changed, 12 insertions(+), 1 deletion(-)
>
> diff --git a/arch/x86/platform/efi/efi.c b/arch/x86/platform/efi/efi.c
> index 3f96a48..1b0efb6 100644
> --- a/arch/x86/platform/efi/efi.c
> +++ b/arch/x86/platform/efi/efi.c
> @@ -41,6 +41,7 @@
> #include <linux/io.h>
> #include <linux/reboot.h>
> #include <linux/bcd.h>
> +#include <linux/module.h>
>
> #include <asm/setup.h>
> #include <asm/efi.h>
> @@ -71,6 +72,13 @@ static efi_system_table_t efi_systab __initdata;
>
> unsigned long x86_efi_facility;
>
> +static bool efivars_no_storage_paranoia;
> +module_param_named(no_storage_paranoia, efivars_no_storage_paranoia, bool, 0644);
Could you rename this to 'efi_no_storage_paranoia' so that it isn't
confused with drivers/firmware/efivars.c? Also, it would be a good idea
to document this new kernel parameter in Documentation/kernel-parameters.
> +MODULE_PARM_DESC(no_storage_paranoia, "Use this parameter only if you are very"
> + " sure that your EFI implemenation does sane garbage"
> + " collection and fulfills the UEFI spec."
> + " Otherwise your board may brick."
> + " See: http://mjg59.dreamwidth.org/#entry-22855");
I think we should avoid including urls in the kernel source. The rest of
the description is fine.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists