[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <518AAE01.2010005@hurleysoftware.com>
Date: Wed, 08 May 2013 15:56:49 -0400
From: Peter Hurley <peter@...leysoftware.com>
To: Wang YanQing <udknight@...il.com>, airlied@...hat.com,
linux-kernel@...r.kernel.org
CC: gregkh@...uxfoundation.org, jslaby@...e.cz, alan@...ux.intel.com
Subject: Re: [PATCH 3/9] vt: delete unneeded functions register_con_driver|take_over_console
On 05/08/2013 02:13 PM, Wang YanQing wrote:
> Now there is no place use register_con_driver|take_over_console,
> and we can achieve their function with do_register_con_driver|
> do_take_over_console easily, so just delete them to reduce code duplication.
>
> Signed-off-by: Wang YanQing <udknight@...il.com>
> ---
> drivers/tty/vt/vt.c | 45 ---------------------------------------------
> include/linux/console.h | 2 --
> 2 files changed, 47 deletions(-)
>
> diff --git a/drivers/tty/vt/vt.c b/drivers/tty/vt/vt.c
> index fbd447b..852d470 100644
> --- a/drivers/tty/vt/vt.c
> +++ b/drivers/tty/vt/vt.c
> @@ -3576,26 +3576,6 @@ err:
> return retval;
> }
>
> -/**
> - * register_con_driver - register console driver to console layer
> - * @csw: console driver
> - * @first: the first console to take over, minimum value is 0
> - * @last: the last console to take over, maximum value is MAX_NR_CONSOLES -1
> - *
> - * DESCRIPTION: This function registers a console driver which can later
> - * bind to a range of consoles specified by @first and @last. It will
> - * also initialize the console driver by calling con_startup().
> - */
> -int register_con_driver(const struct consw *csw, int first, int last)
> -{
> - int retval;
> -
> - console_lock();
> - retval = do_register_con_driver(csw, first, last);
> - console_unlock();
> - return retval;
> -}
> -EXPORT_SYMBOL(register_con_driver);
Maybe register_con_driver() should print a deprecated warning
for a release or two before we remove it.
> /**
> * unregister_con_driver - unregister console driver from console layer
> @@ -3677,30 +3657,6 @@ int do_take_over_console(const struct consw *csw, int first, int last, int deflt
> }
> EXPORT_SYMBOL_GPL(do_take_over_console);
>
> -/*
> - * If we support more console drivers, this function is used
> - * when a driver wants to take over some existing consoles
> - * and become default driver for newly opened ones.
> - *
> - * take_over_console is basically a register followed by unbind
> - */
> -int take_over_console(const struct consw *csw, int first, int last, int deflt)
> -{
> - int err;
> -
> - err = register_con_driver(csw, first, last);
> - /*
> - * If we get an busy error we still want to bind the console driver
> - * and return success, as we may have unbound the console driver
> - * but not unregistered it.
> - */
> - if (err == -EBUSY)
> - err = 0;
> - if (!err)
> - bind_con_driver(csw, first, last, deflt);
> -
> - return err;
> -}
>
> /*
> * give_up_console is a wrapper to unregister_con_driver. It will only
> @@ -4264,6 +4220,5 @@ EXPORT_SYMBOL(console_blanked);
> EXPORT_SYMBOL(vc_cons);
> EXPORT_SYMBOL(global_cursor_default);
> #ifndef VT_SINGLE_DRIVER
> -EXPORT_SYMBOL(take_over_console);
This effectively converts take_over_console() to require GPL now.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists