[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <201305162103.11996.PeterHuewe@gmx.de>
Date: Thu, 16 May 2013 21:03:11 +0200
From: Peter Hüwe <PeterHuewe@....de>
To: tpmdd-devel@...ts.sourceforge.net
Cc: Mathias LEBLANC <Mathias.LEBLANC@...com>,
"Jean-Luc BLANC" <jean-luc.blanc@...com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
Rajiv Andrade <mail@...jiv.net>, Sirrix AG <tpmdd@...rix.com>
Subject: Re: [tpmdd-devel] [PATCH 1/1] TPM: STMicroelectronics st33 driver SPI
Hi Matthias:
> Regarding the while loop, I don't see how can I check the number of dummy
> byte differently?
Checking the number of dummy bytes is fine -
in line #144 you check it with a while loop which looks fine
in line #198 you check it with a for loop with an empty body, which in my
opinion looks less nice than the while in #144.
So simply replace the second instance in #198 and I'm happy with that part ;)
Maybe also have a look at memchr_inv
/**
* memchr_inv - Find an unmatching character in an area of memory.
* @start: The memory area
* @c: Find a character other than c
* @bytes: The size of the area.
*
* returns the address of the first character other than @c, or %NULL
* if the whole buffer contains just @c.
*/
void *memchr_inv(const void *start, int c, size_t bytes)
so #198 would look something like:
nbr_dummy_bytes = memchr_inv (xfer.rx_buf+nbr_dummy_bytes,
0,
total_length-nbr_dummy_bytes) - xfer.rx_buf;
But I'm not sure whether that's more readable, maybe give it a try.
I'm also fine with the while loop.
Peter
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists