lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 20 May 2013 07:37:39 -0700
From:	"Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>
To:	linux-kernel@...r.kernel.org
Cc:	mingo@...e.hu, laijs@...fujitsu.com, dipankar@...ibm.com,
	akpm@...ux-foundation.org, mathieu.desnoyers@...icios.com,
	josh@...htriplett.org, niv@...ibm.com, tglx@...utronix.de,
	peterz@...radead.org, rostedt@...dmis.org, Valdis.Kletnieks@...edu,
	dhowells@...hat.com, edumazet@...gle.com, darren@...art.com,
	fweisbec@...il.com, sbw@....edu
Subject: [PATCH tip/core/rcu 0/8] v2 RCU callback-numbering simplifications
 for 3.11

Hello!

This series takes advantage of callback numbering to simplify RCU's
grace-period machinery, in some cases also reducing the number of
lock acquisitions (though the resulting change in performance is not
perceptible).  The individual patches are as follows:

1.	Move code to make way for the code-combining in later patches.
	This commit makes no changes, just moves code.

2.	Make __note_new_gpnum() also check for the ends of prior grace
	periods, thus eliminating the earlier possibility of a given
	CPU becoming aware of the start of the next grace period before
	becoming aware of the end of the previous grace period.  Yes,
	the code did handle this correctly, but now it doesn't need to.
	More important, now I don't need to think about how it handles
	this correctly.

3.	Rename note_new_gpnum() to note_gp_changes() in preparation for
	later merge of rcu_process_gp_end() into this function.

4.	Change calls to rcu_process_gp_end() to instead call
	note_gp_changes(), and also remove the now-used rcu_process_gp_end().

5.	Remove duplicate code by merging __rcu_process_gp_end() into
	__note_gp_changes().

6.	Eliminate now-redundant call to check_for_new_grace_period().  This
	leaves only a single caller, so inline check_for_new_grace_period().

7.	Given that rcu_start_gp_per_cpu() is a trivial wrapper function
	with only one caller, inline it into its sole remaining call site.

8.	Eliminate now-redundant call to note_gp_changes().

Changes since v1:

o	Added Reviewed-bys.

							Thanx, Paul

 b/kernel/rcutree.c        |  262 ++++++++++++++--------------------------------
 b/kernel/rcutree_plugin.h |    2 
 2 files changed, 85 insertions(+), 179 deletions(-)

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ