[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20130529112929.24005ae9cf1d9d636b2ea42f@linux-foundation.org>
Date: Wed, 29 May 2013 11:29:29 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Seth Jennings <sjenning@...ux.vnet.ibm.com>
Cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Nitin Gupta <ngupta@...are.org>,
Minchan Kim <minchan@...nel.org>,
Konrad Rzeszutek Wilk <konrad.wilk@...cle.com>,
Dan Magenheimer <dan.magenheimer@...cle.com>,
Robert Jennings <rcj@...ux.vnet.ibm.com>,
Jenifer Hopper <jhopper@...ibm.com>,
Mel Gorman <mgorman@...e.de>,
Johannes Weiner <jweiner@...hat.com>,
Rik van Riel <riel@...hat.com>,
Larry Woodman <lwoodman@...hat.com>,
Benjamin Herrenschmidt <benh@...nel.crashing.org>,
Dave Hansen <dave@...1.net>, Joe Perches <joe@...ches.com>,
Joonsoo Kim <iamjoonsoo.kim@....com>,
Cody P Schafer <cody@...ux.vnet.ibm.com>,
Hugh Dickens <hughd@...gle.com>,
Paul Mackerras <paulus@...ba.org>,
Heesub Shin <heesub.shin@...sung.com>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org, devel@...verdev.osuosl.org
Subject: Re: [PATCHv12 3/4] zswap: add to mm/
On Wed, 29 May 2013 09:57:20 -0500 Seth Jennings <sjenning@...ux.vnet.ibm.com> wrote:
> > > +/*********************************
> > > +* helpers
> > > +**********************************/
> > > +static inline bool zswap_is_full(void)
> > > +{
> > > + return (totalram_pages * zswap_max_pool_percent / 100 <
> > > + zswap_pool_pages);
> > > +}
> >
> > We have had issues in the past where percentage-based tunables were too
> > coarse on very large machines. For example, a terabyte machine where 0
> > bytes is too small and 10GB is too large.
>
> Yes, this is known limitation of the code right now and it is a high priority
> to come up with something better. It isn't clear what dynamic sizing policy
> should be used so, until such time as that policy can be determined, this is a
> simple stop-gap that works well enough for simple setups.
It's a module parameter and hence is part of the userspace interface.
It's undesirable that the interface be changed, and it would be rather
dumb to merge it as-is when we *know* that it will be changed.
I don't think we can remove the parameter altogether (or can we?), so I
suggest we finalise it ASAP. Perhaps rename it to
zswap_max_pool_ratio, with a range 1..999999. Better ideas needed :(
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists