lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 05 Jun 2013 08:53:50 +0200
From:	Arne Jansen <>
To:	Jörn Engel <>
CC:	Chris Mason <>,
	Christoph Hellwig <>,
	"" <>,
	"" <>
Subject: Re: [PATCH 0/2] introduce list_for_each_entry_del

On 05.06.2013 04:09, Jörn Engel wrote:
> On Tue, 4 June 2013 14:44:35 -0400, Jörn Engel wrote:
>> Or while_list_drain?

I'm fine with while_list_drain, although a name starting with list_
like all other list macros would be nice. How about just list_drain?
The next question is where to put it in the header so that anyone
doing list cleanup stumbles upon it. Maybe directly below list_del?


> Not sure if the silence is approval or lack of interest, but a new set
> of patches is posted.  By playing around with the implementation a
> bit, I have actually found a variant that makes the object code
> shrink.  Not one variant gave same-size object code.  There's compiler
> optimization for you.
> Jörn
> --
> Money can buy bandwidth, but latency is forever.
> -- John R. Mashey

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists