lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu,  6 Jun 2013 18:10:44 +0200
From:	Johannes Schilling <of82ecuq@....cs.fau.de>
To:	linux-kernel@...r.kernel.org
Cc:	linux-kernel@...cs.fau.de, Al Cho <acho@...ell.com>,
	Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
	Amarjargal Gundjalam <amarjargal16@...il.com>,
	Kurt Kanzenbach <shifty91@...il.com>,
	devel@...verdev.osuosl.org,
	Laura Lawniczak <laura.lawniczak@...glemail.com>,
	Johannes Schilling <of82ecuq@....cs.fau.de>,
	Dan Carpenter <dan.carpenter@...cle.com>
Subject: [PATCH 0/6] keucr: checkpatch fixes

hi,

did some improvement on our previous patch series, see the more detailed
replies below.


[PATCH 1/6] keucr: remove some unneccesary typedefs

On Wed, Jun 05, 2013 at 12:25:02PM +0300, Dan Carpenter wrote:
> On Wed, Jun 05, 2013 at 10:50:01AM +0200, Johannes Schilling wrote:
> > resolves checkpatch.pl warning "do not add new typedefs"
>·
> If you're going to do this, then you may as well give the struct a
> better name at the same time.

did that.



[PATCH 2/6] keucr: use more specific max_t(int, ..

On Wed, Jun 05, 2013 at 12:45:17PM +0300, Dan Carpenter wrote:
> On Wed, Jun 05, 2013 at 10:50:06AM +0200, Johannes Schilling wrote:
> > --- a/drivers/staging/keucr/transport.c
> > +++ b/drivers/staging/keucr/transport.c
> > @@ -708,8 +708,8 @@ int usb_stor_Bulk_transport(struct scsi_cmnd *srb, struct us_data *us)
> >··
> >  »  »   } else {
> >  »  »   »   residue = min(residue, transfer_length);
> > -»  »   »   scsi_set_resid(srb, max(scsi_get_resid(srb),
> > -»  »   »   »   »   »   »   (int) residue));
> > +»  »   »   scsi_set_resid(srb, max_t(int, scsi_get_resid(srb),
> > +»  »   »   »   »   »   »   (int)residue));
>                                                         ^^^^^
> This cast isn't needed any more when you use max_t.

right. i removed it.



[PATCH 3/6] keucr: migrate printk to dev_dbg/info/warn/err

On Wed, Jun 05, 2013 at 02:32:07AM -0700, Dan Carpenter wrote:
> On Wed, Jun 05, 2013 at 10:50:03AM +0200, Johannes Schilling wrote:
> > diff --git a/drivers/staging/keucr/init.c b/drivers/staging/keucr/init.c
> > index a0fdffd..0e8ced1 100644
> > --- a/drivers/staging/keucr/init.c
> > +++ b/drivers/staging/keucr/init.c
> > @@ -19,13 +19,13 @@ int ENE_InitMedia(struct us_data *us)
> >  »  int»result;
> >  »  BYTE»   MiscReg03 = 0;
> >··
> > -»  printk(KERN_INFO "--- Init Media ---\n");
> > +»  dev_info("--- Init Media ---\n");
>·
> Come on people, what's going on here?  This won't compile at all. :/

sorry about that one. fixed, to compile now.
all printks in drivers/staging/keucr/ are now dev_<facility> calls.



[PATCH 4/6] keucr: more readable and friendly error messages

we replaced all error messages that had !! or similar in them with more
neutral ones. also expanded some abbreviations for read/understandability.



[PATCH 5/6] keucr: moved function to other file

migrating printk to dev_<facility> stuff revealed that usb_stor_print_cmd is
(like a lot of functions in this module) declared in init.c, but this one is
only used in transport.c, so we moved it there and made it static.



[PATCH 6/6] keucr: fix some alignment- and whitespace-problems

general alignment and whitespace-fixes, also fix stuff that appears in other
commits but isn't fixed there because they don't deal with
alignment/whitespace.



this all applies cleanly against next-20130605, if necessary i can rediff
against later ones.

regards,
   laura lawniczak, johannes schilling


total diffstat:

Johannes Schilling (3):
  keucr: remove some unneccesary typedefs
  keucr: use more specific max_t(int, ..
  keucr: fix some alignment- and whitespace-problems

Laura Lawniczak (3):
  keucr: migrate printk to dev_dbg/info/warn/err
  keucr: more readable and friendly error messages
  keucr: moved function to other file

 drivers/staging/keucr/init.c      |  102 ++++++++-----------------------
 drivers/staging/keucr/scsiglue.c  |    7 ++-
 drivers/staging/keucr/smil.h      |   28 ++-------
 drivers/staging/keucr/smilmain.c  |  122 ++++++++++++++++++-------------------
 drivers/staging/keucr/smilsub.c   |   27 +++++---
 drivers/staging/keucr/smscsi.c    |    6 +-
 drivers/staging/keucr/transport.c |   58 ++++++++++++++++--
 drivers/staging/keucr/transport.h |    1 -
 drivers/staging/keucr/usb.c       |    8 +--
 drivers/staging/keucr/usb.h       |   30 ++++-----
 10 files changed, 188 insertions(+), 201 deletions(-)

-- 
1.7.10.4

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ