lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 13 Jun 2013 10:30:47 +0300
From:	"Michael S. Tsirkin" <mst@...hat.com>
To:	Rusty Russell <rusty@...tcorp.com.au>
Cc:	Julia Lawall <julia.lawall@...6.fr>,
	Uwe Kleine-König 
	<u.kleine-koenig@...gutronix.de>, Thomas Meyer <thomas@...3r.de>,
	grant.likely@...aro.org, rob.herring@...xeda.com,
	linux-kernel@...r.kernel.org,
	Andrew Morton <akpm@...ux-foundation.org>
Subject: Re: [RFC] PTR_ERR: return 0 if ptr isn't an error value.

On Thu, Jun 13, 2013 at 02:07:40PM +0930, Rusty Russell wrote:
> Julia Lawall <julia.lawall@...6.fr> writes:
> > On Mon, 3 Jun 2013, Uwe Kleine-König wrote:
> > For a random example, here is a function that currently uses PTR_RET:
> 
> Heheh, nice choice: I think I wrote that code originally :)
> 
> > static int __net_init iptable_raw_net_init(struct net *net)
> > {
> >         struct ipt_replace *repl;
> >
> >         repl = ipt_alloc_initial_table(&packet_raw);
> > 	if (repl == NULL)
> >                 return -ENOMEM;
> >         net->ipv4.iptable_raw =
> >                 ipt_register_table(net, &packet_raw, repl);
> > 	kfree(repl);
> >         return PTR_RET(net->ipv4.iptable_raw);
> > }
> >
> > If it becomes return PTR_ERR(...); at the end, won't it look like the 
> > function always fails?
> 
> That is a valid point, though in this case the reader will know that
> can't be the case.
> 
> On the other hand, there's an incremental learning curve cost to every
> convenience function we add.  There are only 50 places where we use
> PTR_RET(), so it's not saving us very much typing over the clearest
> solution: open-coding the test.
> 
> I think using PTR_ERR() is a less bad solution than promoting PTR_RET,
> which has a non-obvious name.
> 
> Cheers,
> Rusty.

Will a longer name make the function more obvious?
	PTR_ERR_OR_ZERO() ?
	PTR_ERR0() ?
PTR_ERR() can then stay simple for cases where we know we
are on the error path.

-- 
MST
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ