[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CANq1E4TmHzdh2cOUXzHCCUFpWsxaNjzyuU=puy1nYevDvHKvWQ@mail.gmail.com>
Date: Thu, 11 Jul 2013 18:07:07 +0200
From: David Herrmann <dh.herrmann@...il.com>
To: Benjamin Tissoires <benjamin.tissoires@...il.com>
Cc: Benjamin Tissoires <benjamin.tissoires@...hat.com>,
Marcel Holtmann <marcel@...tmann.org>,
Gustavo Padovan <gustavo@...ovan.org>,
Jiri Kosina <jkosina@...e.cz>,
"linux-bluetooth@...r.kernel.org" <linux-bluetooth@...r.kernel.org>,
"open list:HID CORE LAYER" <linux-input@...r.kernel.org>,
linux-kernel <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/2] Bluetooth: hidp: implement hidinput_input_event callback
Hi
On Thu, Jul 11, 2013 at 4:10 PM, Benjamin Tissoires
<benjamin.tissoires@...il.com> wrote:
> Hi David,
>
> On Thu, Jul 11, 2013 at 4:02 PM, David Herrmann <dh.herrmann@...il.com> wrote:
>> Hi
>>
>>> +static int hidp_hidinput_event(struct input_dev *dev, unsigned int type,
>>> + unsigned int code, int value)
>>> +{
>>> + struct hid_device *hid = input_get_drvdata(dev);
>>
>> I dislike that we have to deal with input_get_drvdata() in a transport
>> driver. It is not obvious from the transport driver that this gives us
>> an hid_device. But ok, that's how we do it in usbhid and hid-input so
>> it's another issue..
>
> right. So we should definitively change the callback signature here.
>
>>
>>> + struct hidp_session *session = hid->driver_data;
>>> + struct hid_field *field;
>>> + int offset;
>>> +
>>> + BT_DBG("session %p type %d code %d value %d",
>>> + session, type, code, value);
>>> +
>>> + if (type != EV_LED)
>>> + return -1;
>>> +
>>> + offset = hidinput_find_field(hid, type, code, &field);
>>> + if (offset == -1) {
>>> + hid_warn(dev, "event field not found\n");
>>> + return -1;
>>> + }
>>> +
>>> + hid_set_field(field, offset, value);
>>> +
>>> + return hidp_send_report(session, field->report);
>>> +}
>>> +
>>
>> We had this discussion before (regarding uhid and hidpinput_event), it
>> would be nice to have a helper in hid-input.c which does this. We copy
>> the code into every transport driver, which bugs me. But no-one
>> stepped up to do this, so I am fine.
>
> oh, yes, you are right. I'll add it to my todo list (now that I am
> responsible of 2/4 code duplication :-S )
Feel free to push this series forward unchanged, if it is urgent. I
have an experimental series here which implements a generic
hidinput_input_event() handler (including the scheduled worker) that I
will send later today or tomorrow.
Cheers
David
>>
>> Reviewed-by: David Herrmann <dh.herrmann@...il.com>
>
> Thanks for the review!
>
> Cheers,
> Benjamin
>
>>
>> Thanks!
>> David
>>
>>> static int hidp_get_raw_report(struct hid_device *hid,
>>> unsigned char report_number,
>>> unsigned char *data, size_t count,
>>> @@ -711,6 +736,7 @@ static struct hid_ll_driver hidp_hid_driver = {
>>> .stop = hidp_stop,
>>> .open = hidp_open,
>>> .close = hidp_close,
>>> + .hidinput_input_event = hidp_hidinput_event,
>>> };
>>>
>>> /* This function sets up the hid device. It does not add it
>>> --
>>> 1.8.3.1
>>>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists