[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20130720073459.GA5555@gmail.com>
Date: Sat, 20 Jul 2013 09:34:59 +0200
From: Ingo Molnar <mingo@...nel.org>
To: Qiaowei Ren <qiaowei.ren@...el.com>
Cc: Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>,
"H. Peter Anvin" <hpa@...or.com>, x86@...nel.org,
linux-kernel@...r.kernel.org, Gang Wei <gang.wei@...el.com>
Subject: Re: [PATCH] x86, tboot: iomem fixes
* Qiaowei Ren <qiaowei.ren@...el.com> wrote:
> +#define SINIT_MLE_DATA_VTD_DMAR_OFF 140
> /* get addr of DMAR table */
> + dmar_tbl_off = readl(heap_ptr + SINIT_MLE_DATA_VTD_DMAR_OFF);
> dmar_tbl = (struct acpi_table_header *)(heap_ptr +
> - ((struct sinit_mle_data *)heap_ptr)->vtd_dmars_off -
> - sizeof(u64));
> + dmar_tbl_off - sizeof(u64));
So the offset of ->vtd_dmars_off within struct sinit_mle_data is 140?
The new code is less readable: what's wrong with getting the offset
automatically via C, instead of hardcoding it manually? You can use
offsetof() primitive for increased readability.
Thanks,
Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists