lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 05 Aug 2013 15:00:25 +0900
From:	Masami Hiramatsu <masami.hiramatsu.pt@...achi.com>
To:	Namhyung Kim <namhyung@...nel.org>
Cc:	Steven Rostedt <rostedt@...dmis.org>,
	Namhyung Kim <namhyung.kim@....com>,
	Hyeoncheol Lee <cheol.lee@....com>,
	LKML <linux-kernel@...r.kernel.org>,
	Srikar Dronamraju <srikar@...ux.vnet.ibm.com>,
	Oleg Nesterov <oleg@...hat.com>,
	"zhangwei(Jovi)" <jovi.zhangwei@...wei.com>,
	Arnaldo Carvalho de Melo <acme@...stprotocols.net>
Subject: Re: [PATCH 04/13] tracing/kprobes: Factor out struct trace_probe

(2013/07/31 18:03), Namhyung Kim wrote:
> From: Namhyung Kim <namhyung.kim@....com>
> 
> There are functions that can be shared to both of kprobes and uprobes.
> Separate common data structure to struct trace_probe and use it from
> the shared functions.

Thanks, basically I'm good at this change.
Could you also rename several functions which handles trace_kprobe
instead of trace_probe? (as you did on trace_probe_XXX())
e.g.

> @@ -107,14 +91,14 @@ static int kretprobe_dispatcher(struct kretprobe_instance *ri,
>  /*
>   * Allocate new trace_probe and initialize it (including kprobes).
>   */
> -static struct trace_probe *alloc_trace_probe(const char *group,
> +static struct trace_kprobe *alloc_trace_probe(const char *group,

Now this allocates trace_kprobe instead of trace_probe, so
this should be called as alloc_trace_kprobe().
Below functions should also be renamed.

> -static void free_trace_probe(struct trace_probe *tp)
> +static void free_trace_probe(struct trace_kprobe *tp)

> -static struct trace_probe *find_trace_probe(const char *event,
> -					    const char *group)
> +static struct trace_kprobe *find_trace_probe(const char *event,
> +					     const char *group)

> -enable_trace_probe(struct trace_probe *tp, struct ftrace_event_file *file)
> +enable_trace_probe(struct trace_kprobe *tp, struct ftrace_event_file *file)

> -disable_trace_probe(struct trace_probe *tp, struct ftrace_event_file *file)
> +disable_trace_probe(struct trace_kprobe *tp, struct ftrace_event_file *file)

>  /* Internal register function - just handle k*probes and flags */
> -static int __register_trace_probe(struct trace_probe *tp)
> +static int __register_trace_probe(struct trace_kprobe *tp)

>  /* Internal unregister function - just handle k*probes and flags */
> -static void __unregister_trace_probe(struct trace_probe *tp)
> +static void __unregister_trace_probe(struct trace_kprobe *tp)

For below two, comments should be updated too.

>  /* Unregister a trace_probe and probe_event: call with locking probe_lock */
> -static int unregister_trace_probe(struct trace_probe *tp)
> +static int unregister_trace_probe(struct trace_kprobe *tp)

>  /* Register a trace_probe and probe_event */
> -static int register_trace_probe(struct trace_probe *tp)
> +static int register_trace_probe(struct trace_kprobe *tp)

> @@ -399,7 +383,7 @@ static int trace_probe_module_callback(struct notifier_block *nb,
>  				       unsigned long val, void *data)

> @@ -448,7 +432,7 @@ static int create_trace_probe(int argc, char **argv)

>  static int release_all_trace_probes(void)

>  static struct ftrace_event_file *
> -find_trace_probe_file(struct trace_probe *tp, struct trace_array *tr)
> +find_trace_probe_file(struct trace_kprobe *tp, struct trace_array *tr)

Thank you,

-- 
Masami HIRAMATSU
IT Management Research Dept. Linux Technology Center
Hitachi, Ltd., Yokohama Research Laboratory
E-mail: masami.hiramatsu.pt@...achi.com


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists