[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5200F1B4.6050004@infradead.org>
Date: Tue, 06 Aug 2013 05:53:08 -0700
From: Randy Dunlap <rdunlap@...radead.org>
To: Viresh Kumar <viresh.kumar@...aro.org>
CC: rjw@...k.pl, pavel@....cz, linaro-kernel@...ts.linaro.org,
patches@...aro.org, linux-pm@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] OPP: Export opp_add()
On 08/03/2013 02:25 AM, Viresh Kumar wrote:
> Export opp_add() so that modules can use it.
>
> Signed-off-by: Viresh Kumar <viresh.kumar@...aro.org>
> ---
> drivers/base/power/opp.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/base/power/opp.c b/drivers/base/power/opp.c
> index c8ec186..ef89897 100644
> --- a/drivers/base/power/opp.c
> +++ b/drivers/base/power/opp.c
> @@ -460,6 +460,7 @@ int opp_add(struct device *dev, unsigned long freq, unsigned long u_volt)
> srcu_notifier_call_chain(&dev_opp->head, OPP_EVENT_ADD, new_opp);
> return 0;
> }
> +EXPORT_SYMBOL_GPL(opp_add);
Could it be renamed to pm_opp_add() or power_opp_add() ?
The name is a bit too unspecific IMO.
>
> /**
> * opp_set_availability() - helper to set the availability of an opp
>
--
~Randy
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists