[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20130807130906.GD2515@console-pimps.org>
Date: Wed, 7 Aug 2013 14:09:06 +0100
From: Matt Fleming <matt@...sole-pimps.org>
To: Roy Franz <roy.franz@...aro.org>
Cc: linux-kernel@...r.kernel.org, linux-efi@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org, matt.fleming@...el.com,
linux@....linux.org.uk, leif.lindholm@...aro.org,
dave.martin@....com
Subject: Re: [PATCH 04/17] Rename memory allocation/free functions
On Tue, 06 Aug, at 08:45:00PM, Roy Franz wrote:
> Rename them to be more similar, as low_free() could be used to free
> memory allocated by both high_alloc() and low_alloc().
> high_alloc() -> efi_high_alloc()
> low_alloc() -> efi_low_alloc()
> low_free() -> efi_free()
>
> Signed-off-by: Roy Franz <roy.franz@...aro.org>
> ---
> arch/x86/boot/compressed/eboot.c | 19 ++++++++++---------
> drivers/firmware/efi/efi-stub-helper.c | 16 ++++++++--------
> 2 files changed, 18 insertions(+), 17 deletions(-)
[...]
> @@ -163,10 +163,10 @@ fail:
> }
>
> /*
> - * Allocate at the lowest possible address.
> + * Allocate at the lowest possible address, that is not below 'min'
> */
> -static efi_status_t low_alloc(efi_system_table_t *sys_table_arg,
> - unsigned long size, unsigned long align,
> +static efi_status_t efi_low_alloc(efi_system_table_t *sys_table_arg,
> + unsigned long size, unsigned long align,
> unsigned long *addr)
> {
> unsigned long map_size, desc_size;
Whoops, did this change to the comment slip in from some other patch?
--
Matt Fleming, Intel Open Source Technology Center
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists