[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20130813131510.59ef74bce81d9352f8590218@linux-foundation.org>
Date: Tue, 13 Aug 2013 13:15:10 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Xishi Qiu <qiuxishi@...wei.com>
Cc: Cody P Schafer <cody@...ux.vnet.ibm.com>, <linux-mm@...ck.org>,
LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/3] mm: use zone_end_pfn() instead of
zone_start_pfn+spanned_pages
On Wed, 7 Aug 2013 17:09:56 +0800 Xishi Qiu <qiuxishi@...wei.com> wrote:
> Use "zone_end_pfn()" instead of "zone->zone_start_pfn + zone->spanned_pages".
> Simplify the code, no functional change.
This doesn't compile.
mm/memory_hotplug.c: In function 'shrink_zone_span':
mm/memory_hotplug.c:518: error: called object 'zone_end_pfn' is not a function
> kernel/power/snapshot.c | 12 ++++++------
> mm/memory_hotplug.c | 4 ++--
It's only two files - did you test it?
I couldn't see any vaguely acceptable way of renaming the variables to
fix this, so I did a hack which permits us to keep the current naming.
Any better ideas?
--- a/mm/memory_hotplug.c~mm-use-zone_end_pfn-instead-of-zone_start_pfnspanned_pages-fix
+++ a/mm/memory_hotplug.c
@@ -514,8 +514,9 @@ static int find_biggest_section_pfn(int
static void shrink_zone_span(struct zone *zone, unsigned long start_pfn,
unsigned long end_pfn)
{
- unsigned long zone_start_pfn = zone->zone_start_pfn;
- unsigned long zone_end_pfn = zone_end_pfn(zone);
+ unsigned long zone_start_pfn = zone->zone_start_pfn;
+ unsigned long z = zone_end_pfn(zone); /* zone_end_pfn namespace clash */
+ unsigned long zone_end_pfn = z;
unsigned long pfn;
struct mem_section *ms;
int nid = zone_to_nid(zone);
_
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists