lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 19 Aug 2013 20:20:14 -0700
From:	Josh Triplett <josh@...htriplett.org>
To:	"Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>
Cc:	linux-kernel@...r.kernel.org, mingo@...e.hu, laijs@...fujitsu.com,
	dipankar@...ibm.com, akpm@...ux-foundation.org,
	mathieu.desnoyers@...ymtl.ca, niv@...ibm.com, tglx@...utronix.de,
	peterz@...radead.org, rostedt@...dmis.org, dhowells@...hat.com,
	edumazet@...gle.com, darren@...art.com, fweisbec@...il.com,
	sbw@....edu, Mathieu Desnoyers <mathieu.desnoyers@...icios.com>,
	Sedat Dilek <sedat.dilek@...il.com>,
	Davidlohr Bueso <davidlohr.bueso@...com>,
	Rik van Riel <riel@...riel.com>,
	Linus Torvalds <torvalds@...ux-foundation.org>
Subject: Re: [PATCH tip/core/rcu 1/5] rcu: Add duplicate-callback tests to
 rcutorture

On Mon, Aug 19, 2013 at 07:05:58PM -0700, Paul E. McKenney wrote:
> On Mon, Aug 19, 2013 at 10:16:52AM -0700, Josh Triplett wrote:
> > On Mon, Aug 19, 2013 at 09:09:45AM -0700, Paul E. McKenney wrote:
> > > On Sun, Aug 18, 2013 at 09:19:25PM -0700, Josh Triplett wrote:
> > > > On Sun, Aug 18, 2013 at 08:55:28PM -0700, Paul E. McKenney wrote:
> > > > > On Sat, Aug 17, 2013 at 07:54:20PM -0700, Josh Triplett wrote:
> > > > > > On Sat, Aug 17, 2013 at 07:25:13PM -0700, Paul E. McKenney wrote:
> > > > > > > From: "Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>
> > > > > > > 
> > > > > > > This commit adds a object_debug option to rcutorture to allow the
> > > > > > > debug-object-based checks for duplicate call_rcu() invocations to
> > > > > > > be deterministically tested.
> > > > > > > 
> > > > > > > Signed-off-by: Paul E. McKenney <paulmck@...ux.vnet.ibm.com>
> > > > > > > Cc: Mathieu Desnoyers <mathieu.desnoyers@...icios.com>
> > > > > > > Cc: Sedat Dilek <sedat.dilek@...il.com>
> > > > > > > Cc: Davidlohr Bueso <davidlohr.bueso@...com>
> > > > > > > Cc: Rik van Riel <riel@...riel.com>
> > > > > > > Cc: Thomas Gleixner <tglx@...utronix.de>
> > > > > > > Cc: Linus Torvalds <torvalds@...ux-foundation.org>
> > > > > > > Tested-by: Sedat Dilek <sedat.dilek@...il.com>
> > > > > > 
> > > > > > Two comments below; with those fixed,
> > > > > > Reviewed-by: Josh Triplett <josh@...htriplett.org>
> > > > > > 
> > > > > > > ---
> > > > > > > @@ -100,6 +101,8 @@ module_param(fqs_stutter, int, 0444);
> > > > > > >  MODULE_PARM_DESC(fqs_stutter, "Wait time between fqs bursts (s)");
> > > > > > >  module_param(n_barrier_cbs, int, 0444);
> > > > > > >  MODULE_PARM_DESC(n_barrier_cbs, "# of callbacks/kthreads for barrier testing");
> > > > > > > +module_param(object_debug, int, 0444);
> > > > > > > +MODULE_PARM_DESC(object_debug, "Enable debug-object double call_rcu() testing");
> > > > > > 
> > > > > > modules-next has a change to ignore and warn about
> > > > > > unknown module parameters.  Thus, I'd suggest wrapping the ifdef around
> > > > > > this module parameter, so it doesn't exist at all without
> > > > > > CONFIG_DEBUG_OBJECTS_RCU_HEAD.
> > > > > > 
> > > > > > Alternatively, consider providing the test unconditionally, and just
> > > > > > printing a big warning message saying that it's going to cause
> > > > > > corruption in the !CONFIG_DEBUG_OBJECTS_RCU_HEAD case.
> > > > > 
> > > > > I currently do something like the above.  The module parameter
> > > > > is defined unconditionally, but the actual tests are under #ifdef
> > > > > CONFIG_DEBUG_OBJECTS_RCU_HEAD.  If you specify object_debug for a
> > > > > !CONFIG_DEBUG_OBJECTS_RCU_HEAD kernel, the pr_alert() below happens,
> > > > > and the test is omitted, thus avoiding the list corruption.
> > > > > 
> > > > > Seem reasonable?
> > > > 
> > > > That's exactly the bit I was commenting on.  I'm saying that you should
> > > > either make the test unconditional (perhaps with a warning saying it's
> > > > about to cause list corruption), or you should compile out the module
> > > > parameter as well and then you don't need the pr_alert (since current
> > > > kernels will emit a warning when you pass a non-existent module
> > > > parameter).
> > > > 
> > > > Personally, I'd go with the latter.
> > > 
> > > Ah, the problem is the ugly ifdef in the middle of a function.  Yeah,
> > > that is a problem in need of fixing.  No idea what I was thinking...
> > > 
> > > How about if I pull that block of code out into its own function, and
> > > #ifdef the function body.  For example, something like that shown below.
> > [...]
> > > static void rcu_test_debug_objects(void)
> > > {
> > > #ifdef CONFIG_DEBUG_OBJECTS_RCU_HEAD
> > > 	struct rcu_head rh1;
> > > 	struct rcu_head rh2;
> > > 
> > > 	init_rcu_head_on_stack(&rh1);
> > > 	init_rcu_head_on_stack(&rh2);
> > > 	pr_alert("rcutorture: WARN: Duplicate call_rcu() test starting.\n");
> > > 	local_irq_disable(); /* Make it hard to finish grace period. */
> > > 	call_rcu(&rh1, rcu_torture_leak_cb); /* start grace period. */
> > > 	call_rcu(&rh2, rcu_torture_err_cb);
> > > 	call_rcu(&rh2, rcu_torture_err_cb); /* duplicate callback. */
> > > 	local_irq_enable();
> > > 	rcu_barrier();
> > > 	pr_alert("rcutorture: WARN: Duplicate call_rcu() test complete.\n");
> > > 	destroy_rcu_head_on_stack(&rh1);
> > > 	destroy_rcu_head_on_stack(&rh2);
> > > #else /* #ifdef CONFIG_DEBUG_OBJECTS_RCU_HEAD */
> > > 	pr_alert("rcutorture: !CONFIG_DEBUG_OBJECTS_RCU_HEAD, not testing duplicate call_rcu()\n");
> > > #endif /* #else #ifdef CONFIG_DEBUG_OBJECTS_RCU_HEAD */
> > > }
> > 
> > That's a major improvement, but I'd still suggest a couple more changes:
> > move the if for the config option into that function inside the ifdef,
> > wrap the config parameter itself in an ifdef so it doesn't exist without
> > CONFIG_DEBUG_OBJECTS_RCU_HEAD, and drop the #else branch since the
> > kernel will already emit a warning if you use the module parameter with
> > !CONFIG_DEBUG_OBJECTS_RCU_HEAD.
> 
> I really feel the need to distinguish between "that is never a valid
> parameter to rcutorture" (given by the module-parameter parser) and
> "that parameter is valid, but cannot be used in this case, and here
> are the consequences", so I will keep the pr_alert().  But definitely
> fix the mid-function #ifdef!

OK; I can live with that.
Reviewed-by: Josh Triplett <josh@...htriplett.org>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ