[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <1377387845.32763.149.camel@haakon3.risingtidesystems.com>
Date: Sat, 24 Aug 2013 16:44:05 -0700
From: "Nicholas A. Bellinger" <nab@...ux-iscsi.org>
To: Christoph Hellwig <hch@...radead.org>
Cc: "Nicholas A. Bellinger" <nab@...erainc.com>,
target-devel <target-devel@...r.kernel.org>,
lkml <linux-kernel@...r.kernel.org>,
linux-scsi <linux-scsi@...r.kernel.org>,
Christoph Hellwig <hch@....de>, Hannes Reinecke <hare@...e.de>,
Martin Petersen <martin.petersen@...cle.com>,
Chris Mason <chris.mason@...ionio.com>,
Roland Dreier <roland@...estorage.com>,
James Bottomley <JBottomley@...allels.com>
Subject: Re: [PATCH-v2 06/12] target: Add memory allocation for
bidirectional commands
On Sat, 2013-08-24 at 08:18 -0700, Christoph Hellwig wrote:
> > static int
> > +transport_generic_get_mem_bidi(struct se_cmd *cmd)
>
> Except for the fields touched in struct se_cmd this is a duplication
> of transport_generic_get_mem. I'd suggest to factor that one into
> a new helper:
>
> static int
> target_alloc_sgl(struct scatterlist **sgl, unsigned int **nents,
> u32 length, gfp_t gfp_mask)
> {
> ..
> }
>
> and then call that one from transport_generic_new_cmd directly,
Sounds reasonable enough, doing that bit of refactoring now..
> including opencoding the actual BIDI case there as a first step.
>
Not sure why this needs to be opencoded for BIDI, instead of just doing
target_alloc_sgl(&cmd->t_bidi_data_sg, ...) for the two SCF_BIDI ||
SCF_COMPARE_AND_WRITE cases in transport_generic_new_cmd()..?
--nab
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists