[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CACRpkdb5fqMycTxou50-+oiNOs3vzd+8XfWsPbX8vBJp2Su3aw@mail.gmail.com>
Date: Fri, 20 Sep 2013 21:21:37 +0200
From: Linus Walleij <linus.walleij@...aro.org>
To: Mika Westerberg <mika.westerberg@...ux.intel.com>
Cc: "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"Rafael J. Wysocki" <rafael.j.wysocki@...el.com>,
Mathias Nyman <mathias.nyman@...ux.intel.com>,
Grant Likely <grant.likely@...retlab.ca>,
ACPI Devel Maling List <linux-acpi@...r.kernel.org>,
Alexandre Courbot <acourbot@...dia.com>
Subject: Re: [PATCH 2/2] gpio / ACPI: add support for GPIO operation regions
On Fri, Sep 13, 2013 at 5:14 PM, Mika Westerberg
<mika.westerberg@...ux.intel.com> wrote:
> diff --git a/drivers/gpio/gpiolib-acpi.c b/drivers/gpio/gpiolib-acpi.c
(...)
> +struct acpi_gpio_chip_data {
> + /*
> + * acpi_install_address_space_handler() wants to put the connection
> + * information at the start of the context structure we pass it, in
> + * case we are dealing with GPIO operation regions.
> + */
> + struct acpi_connection_info ci;
> + struct gpio_chip *chip;
> + struct list_head *evt_pins;
> +};
Consider just naming this acpi_gpio_chip, as it is obviously some
generic container that you will keep adding to.
I'm uncertain how things work, it wouldn't add something to have
struct gpio_chip be a true member (not a pointer) so you can
allocate one thing from the drivers, and e.g. use container_of()
to get from the gpio_chip to the acpi_gpio_chip[_data]?
Yours,
Linus Walleij
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists