[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20130925105330.4b717a80@gandalf.local.home>
Date: Wed, 25 Sep 2013 10:53:30 -0400
From: Steven Rostedt <rostedt@...dmis.org>
To: Jiang Liu <liuj97@...il.com>
Cc: Catalin Marinas <catalin.marinas@....com>,
Will Deacon <will.deacon@....com>,
Jiang Liu <jiang.liu@...wei.com>,
Andrew Jones <drjones@...hat.com>,
Raghavendra K T <raghavendra.kt@...ux.vnet.ibm.com>,
Konrad Rzeszutek Wilk <konrad.wilk@...cle.com>,
"H. Peter Anvin" <hpa@...ux.intel.com>,
linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCH v1 7/7] jump_label: use defined macros instead of
hard-coding for better readability
On Wed, 25 Sep 2013 18:44:27 +0800
Jiang Liu <liuj97@...il.com> wrote:
> From: Jiang Liu <jiang.liu@...wei.com>
>
> Use macro JUMP_LABEL_TRUE_BRANCH instead of hard-coding for better
> readability.
>
> Signed-off-by: Jiang Liu <jiang.liu@...wei.com>
> Cc: Jiang Liu <liuj97@...il.com>
> ---
> include/linux/jump_label.h | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/include/linux/jump_label.h b/include/linux/jump_label.h
> index a507907..b697fbd 100644
> --- a/include/linux/jump_label.h
> +++ b/include/linux/jump_label.h
> @@ -116,7 +116,8 @@ extern void static_key_slow_dec(struct static_key *key);
> extern void jump_label_apply_nops(struct module *mod);
>
> #define STATIC_KEY_INIT_TRUE ((struct static_key) \
> - { .enabled = ATOMIC_INIT(1), .entries = (void *)1 })
> + { .enabled = ATOMIC_INIT(1), \
> + .entries = (void *)JUMP_LABEL_TRUE_BRANCH })
> #define STATIC_KEY_INIT_FALSE ((struct static_key) \
> { .enabled = ATOMIC_INIT(0), .entries = (void *)0 })
>
Probably should add a comment that there is no
"JUMP_LABEL_FALSE_BRANCH" or maybe we should add one?
-- Steve
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists