[<prev] [next>] [day] [month] [year] [list]
Message-ID: <52540559.6030406@nvidia.com>
Date: Tue, 8 Oct 2013 18:45:05 +0530
From: Laxman Dewangan <ldewangan@...dia.com>
To: Mike Turquette <mturquette@...aro.org>
CC: "broonie@...aro.org" <broonie@...aro.org>,
"rob.herring@...xeda.com" <rob.herring@...xeda.com>,
"pawel.moll@....com" <pawel.moll@....com>,
"mark.rutland@....com" <mark.rutland@....com>,
"ijc+devicetree@...lion.org.uk" <ijc+devicetree@...lion.org.uk>,
"grant.likely@...aro.org" <grant.likely@...aro.org>,
"rob@...dley.net" <rob@...dley.net>,
"devicetree@...r.kernel.org" <devicetree@...r.kernel.org>,
"linux-doc@...r.kernel.org" <linux-doc@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"linux-arm-kernel@...ts.infradead.org"
<linux-arm-kernel@...ts.infradead.org>,
Stephen Warren <swarren@...dia.com>
Subject: Re: [PATCH V2] clk: palmas: add clock driver for palmas
On Tuesday 08 October 2013 06:32 AM, Mike Turquette wrote:
> Quoting Laxman Dewangan (2013-10-07 07:05:51)
>> + if (!ret) {
>> + switch (prop) {
>> + case 1:
>> + prop = PALMAS_EXT_CONTROL_ENABLE1;
>> + break;
>> + case 2:
>> + prop = PALMAS_EXT_CONTROL_ENABLE2;
>> + break;
>> + case 3:
>> + prop = PALMAS_EXT_CONTROL_NSLEEP;
>> + break;
> Can magic numbers be replaced with defines?
Fine, will do in V3.
>
>
> +
> + ret = palmas_update_bits(palmas_clks->palmas, PALMAS_RESOURCE_BASE,
> + cinfo->clk_desc->control_reg,
> + cinfo->clk_desc->sleep_mask, 0);
> What does this call to palmas_update_bits do?
This APIs update the selected bits based on mask. This is wrapper over
the regmap_update_bits() to provide the interface at the Palmas register
access.
The palmas registers are paged on different i2c address and offset. The
i2c address and offset is decided based on base_address and offset.
This APIs does all calculation to get the correct i2c slave address and
offset address based on argument.
>> +static int palmas_clks_remove(struct platform_device *pdev)
>> +{
>> + of_clk_del_provider(pdev->dev.of_node);
> I'll be taking Sylwester's clock deregistration series after he
> publishes the next version, so if you want to call clk_unregister here
> (based on the new call) you could.
>
> If you want to add that in a later patch it is OK.
Thanks for pointing me this changes. I like to add this on my follow on
(later) patch, not on this. -- 1.7.1.1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists