[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <526764EA.9000002@gmail.com>
Date: Wed, 23 Oct 2013 06:55:54 +0100
From: David Ahern <dsahern@...il.com>
To: Adrian Hunter <adrian.hunter@...el.com>,
Arnaldo Carvalho de Melo <acme@...stprotocols.net>
CC: Peter Zijlstra <a.p.zijlstra@...llo.nl>,
Ingo Molnar <mingo@...hat.com>, linux-kernel@...r.kernel.org,
Frederic Weisbecker <fweisbec@...il.com>,
Jiri Olsa <jolsa@...hat.com>, Mike Galbraith <efault@....de>,
Namhyung Kim <namhyung@...il.com>,
Paul Mackerras <paulus@...ba.org>,
Stephane Eranian <eranian@...gle.com>
Subject: Re: [PATCH V2 03/14] perf script: Make perf_script a local variable
On 10/22/13 8:34 AM, Adrian Hunter wrote:
> -static int __cmd_script(struct perf_session *session)
> +static int __cmd_script(struct perf_script *scr)
for naming consistency that should be *script.
> {
> int ret;
>
> signal(SIGINT, sig_handler);
>
> - ret = perf_session__process_events(session, &perf_script);
> + ret = perf_session__process_events(scr->session, &scr->tool);
>
> if (debug_mode)
> pr_err("Misordered timestamps: %" PRIu64 "\n", nr_unordered);
> @@ -1273,6 +1264,21 @@ int cmd_script(int argc, const char **argv, const char *prefix __maybe_unused)
> char *script_path = NULL;
> const char **__argv;
> int i, j, err;
> + struct perf_script perf_script = {
Ditto: struct perf_script script;
Otherwise the change looks fine to me.
Acked-by: David Ahern <dsahern@...il.com>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists