lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 31 Oct 2013 09:22:30 +0100
From:	Ingo Molnar <>
To:	Masami Hiramatsu <>
Cc:	Fenghua Yu <>,
	Seiji Aguchi <>,
	Ananth N Mavinakayanahalli <>,, lkml <>,
	"Steven Rostedt (Red Hat)" <>,
	Ingo Molnar <>,
	"H. Peter Anvin" <>,
	Thomas Gleixner <>,
	Borislav Petkov <>
Subject: Re: [PATCH -tip 1/2] [BUGFIX] kprobes/x86: Prohibit probing on

* Masami Hiramatsu <> wrote:

> -int is_debug_stack(unsigned long addr)
> +int __kprobes is_debug_stack(unsigned long addr)

_Please_ add a __noprobes method, for new annotations.

Naming it '__kprobes' is actively confusing, as it suggests that the 
function is somehow positively involved with kprobes support. 
Instead it should the noinline/notrace pattern.

I complained about this before and not much happened on this front. 
We might not want to convert the whole kernel straight away, but for 
_new_ annotations there's no excuse not to name them properly. Lets 
phase out __kprobes, and use __noprobe from now on, okay?


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists