[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20131101225236.GB17505@beef>
Date: Fri, 1 Nov 2013 18:52:36 -0400
From: Matt Porter <matt.porter@...aro.org>
To: Sergei Shtylyov <sergei.shtylyov@...entembedded.com>
Cc: Felipe Balbi <balbi@...com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Kishon Vijay Abraham I <kishon@...com>,
Rob Herring <rob.herring@...xeda.com>,
Pawel Moll <pawel.moll@....com>,
Mark Rutland <mark.rutland@....com>,
Kumar Gala <galak@...eaurora.org>,
Ian Campbell <ijc+devicetree@...lion.org.uk>,
Christian Daudt <bcm@...thebug.org>,
Paul Zimmerman <paulz@...opsys.com>,
Linux USB List <linux-usb@...r.kernel.org>,
Linux ARM Kernel List <linux-arm-kernel@...ts.infradead.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Devicetree List <devicetree@...r.kernel.org>,
Linaro Patches <patches@...aro.org>
Subject: Re: [PATCH v2 9/9] ARM: dts: add usb udc support to bcm281xx
On Fri, Nov 01, 2013 at 11:56:33PM +0300, Sergei Shtylyov wrote:
> Hello.
>
> On 11/01/2013 10:45 PM, Matt Porter wrote:
>
> >Adds USB OTG/PHY and clock support to BCM281xx and enables
> >UDC support on the bcm11351-brt and bcm28155-ap boards.
>
> >Signed-off-by: Matt Porter <matt.porter@...aro.org>
> >Reviewed-by: Markus Mayer <markus.mayer@...aro.org>
> >Reviewed-by: Tim Kryger <tim.kryger@...aro.org>
> >---
> > arch/arm/boot/dts/bcm11351-brt.dts | 6 ++++++
> > arch/arm/boot/dts/bcm11351.dtsi | 18 ++++++++++++++++++
> > arch/arm/boot/dts/bcm28155-ap.dts | 8 ++++++++
> > 3 files changed, 32 insertions(+)
>
> [...]
> >diff --git a/arch/arm/boot/dts/bcm11351.dtsi b/arch/arm/boot/dts/bcm11351.dtsi
> >index 0755f43..247f9fd 100644
> >--- a/arch/arm/boot/dts/bcm11351.dtsi
> >+++ b/arch/arm/boot/dts/bcm11351.dtsi
> >@@ -284,4 +284,22 @@
> > #clock-cells = <0>;
> > };
> > };
> >+
> >+ usbotg: usbotg@...20000 {
>
> According to ePAPR spec [1], the node name should be "usb@...20000".
Will address in v3.
> >+ compatible = "snps,dwc2";
> >+ reg = <0x3f120000 0x10000>;
> >+ interrupts = <GIC_SPI 47 IRQ_TYPE_LEVEL_HIGH>;
> >+ clocks = <&usb_otg_ahb_clk>;
> >+ clock-names = "otg";
> >+ phys = <&usbphy>;
> >+ phy-names = "usb2-phy";
> >+ status = "disabled";
> >+ };
> >+
> >+ usbphy: usbphy@...30000 {
>
> This one should probably be named "usb-phy@...30000", just like
> "ethernet-phy" from the ePAPR spec.
Yes, agreed that will follow the same naming convention. I'll roll this
in v3. Thanks for the review.
-Matt
> >+ compatible = "brcm,kona-usb2-phy";
> >+ reg = <0x3f130000 0x28>;
> >+ #phy-cells = <0>;
> >+ status = "disabled";
> >+ };
> > };
>
> [1] http://www.power.org/resources/downloads/Power_ePAPR_APPROVED_v1.0.pdf
>
> WBR, Sergei
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists