lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Thu, 7 Nov 2013 10:03:38 -0600
From:	Chris Bagwell <chris@...bagwell.com>
To:	matthew@...omplete.io
Cc:	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	"linux-input@...r.kernel.org" <linux-input@...r.kernel.org>
Subject: Re: [PATCH] INPUT: wacom: Added definition for Wacom CTH680 The Wacom
 Creative Pen & Touch Tablet M (CTH680, 056A:0303) is a newer revision of the
 Bamboo series. This patch adds product 0303 to wacom.ko.

On Sat, Nov 2, 2013 at 2:04 PM,  <matthew@...omplete.io> wrote:
> From: Matthew Geddes <matthew@...omplete.io>
>

Your whole commit message appears to be crammed into first summary
line.  Could you please align with git conventions: put a line break
after "CTH680", a blank line, and then the remaining description
afterwards.

> Signed-off-by: Matthew Geddes <matthew@...omplete.io>
> ---
>  drivers/input/tablet/wacom_wac.c | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/drivers/input/tablet/wacom_wac.c b/drivers/input/tablet/wacom_wac.c
> index c59b797..5015269 100644
> --- a/drivers/input/tablet/wacom_wac.c
> +++ b/drivers/input/tablet/wacom_wac.c
> @@ -2128,6 +2128,9 @@ static const struct wacom_features wacom_features_0x300 =
>  static const struct wacom_features wacom_features_0x301 =
>         { "Wacom Bamboo One M",    WACOM_PKGLEN_BBPEN,    21648, 13530, 1023,
>           31, BAMBOO_PT, WACOM_INTUOS_RES, WACOM_INTUOS_RES };
> +static const struct wacom_features wacom_features_0x303 =
> +       { "Wacom Creative Touch & Pen M", WACOM_PKGLEN_BBPEN, 21648, 13530,

A search for model CTH680 shows this device is the newly released
"Intuos Pen & Touch Medium"; which is also the new name for Bamboo's
and with new form factor.  I do see occasional site that added
Creative in there: "Intuos Creative Pen & Touch Medium".  Can you
confirm if this is the model you have?

I'd suggest using Wacom's terms closer (add in Intuos and swap Pen &
Touch to their order; maybe drop phrase Creative).

Also, the 21648/13530 values look copy&pasted from previous line.  Can
you use "evtest" or similar to find real maximum values.  Previous
"Bamboo Touch" models had 13700 as second number.  Since your tablet
has different shape from previous Bamboo and the "Bamboo One" then
there is good change you need unique values to get full usable area of
tablet.

> +         1023, 31, BAMBOO_PT, WACOM_INTUOS_RES, WACOM_INTUOS_RES };

Can you update patch to exactly follow form of structures surrounding
it?  Namely, put the "1023" value on first line like rest of lines do.

Thanks!
Chris


>  static const struct wacom_features wacom_features_0x6004 =
>         { "ISD-V4",               WACOM_PKGLEN_GRAPHIRE,  12800,  8000,  255,
>           0, TABLETPC, WACOM_INTUOS_RES, WACOM_INTUOS_RES };
> @@ -2258,6 +2261,7 @@ const struct usb_device_id wacom_ids[] = {
>         { USB_DEVICE_WACOM(0x10F) },
>         { USB_DEVICE_WACOM(0x300) },
>         { USB_DEVICE_WACOM(0x301) },
> +       { USB_DEVICE_WACOM(0x303) },
>         { USB_DEVICE_WACOM(0x304) },
>         { USB_DEVICE_WACOM(0x4001) },
>         { USB_DEVICE_WACOM(0x47) },
> --
> 1.8.3.2
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-input" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ