[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <528E3CBC.7090204@infradead.org>
Date: Thu, 21 Nov 2013 09:02:52 -0800
From: Randy Dunlap <rdunlap@...radead.org>
To: Richard Weinberger <richard@....at>
CC: user-mode-linux-devel@...ts.sourceforge.net,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] um: Rename print_stack_trace to do_stack_trace
On 11/21/13 00:31, Richard Weinberger wrote:
> We cannot use print_stack_trace because the name conflicts
> with linux/stacktrace.h.
>
> Reported-by: Randy Dunlap <rdunlap@...radead.org>
> Signed-off-by: Richard Weinberger <richard@....at>
Acked-by: Randy Dunlap <rdunlap@...radead.org>
Thanks.
> ---
> arch/um/kernel/sysrq.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/um/kernel/sysrq.c b/arch/um/kernel/sysrq.c
> index 4d6fdf6..799d7e4 100644
> --- a/arch/um/kernel/sysrq.c
> +++ b/arch/um/kernel/sysrq.c
> @@ -19,7 +19,7 @@ struct stack_frame {
> unsigned long return_address;
> };
>
> -static void print_stack_trace(unsigned long *sp, unsigned long bp)
> +static void do_stack_trace(unsigned long *sp, unsigned long bp)
> {
> int reliable;
> unsigned long addr;
> @@ -94,5 +94,5 @@ void show_stack(struct task_struct *task, unsigned long *stack)
> }
> printk(KERN_CONT "\n");
>
> - print_stack_trace(sp, bp);
> + do_stack_trace(sp, bp);
> }
>
--
~Randy
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists