[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20131129094652.GK4186@dhcp-16-126.nay.redhat.com>
Date: Fri, 29 Nov 2013 17:46:52 +0800
From: Dave Young <dyoung@...hat.com>
To: Matt Fleming <matt@...sole-pimps.org>
Cc: linux-kernel@...r.kernel.org, linux-efi@...r.kernel.org,
x86@...nel.org, mjg59@...f.ucam.org, hpa@...or.com,
James.Bottomley@...senPartnership.com, vgoyal@...hat.com,
ebiederm@...ssion.com, horms@...ge.net.au,
kexec@...ts.infradead.org, bp@...en8.de, greg@...ah.com,
toshi.kani@...com
Subject: Re: [PATCH v4 07/12] efi: passing kexec necessary efi data via
setup_data
On 11/27/13 at 10:17am, Matt Fleming wrote:
> On Wed, 27 Nov, at 12:52:37PM, Dave Young wrote:
> > To make it more readable, I will change them like below:
> >
> > p = efi_runtime_map;
> > md = efi_setup->map;
> > for (i = 0; i < nr_efi_runtime_map; i++) {
> > [...]
> > md += 1;
> > }
>
> Actually, md++ is the canonical way to write this.
Ok.
>
> > >
> > > > + efi_map_region_fixed(md);
> > > > + size = md->num_pages << PAGE_SHIFT;
> > > > + end = md->phys_addr + size;
> > > > +
> > > > + systab = (u64) (unsigned long) efi_phys.systab;
> > > > + if (md->phys_addr <= systab && systab < end) {
> > > > + systab += md->virt_addr - md->phys_addr;
> > > > + efi.systab =
> > > > + (efi_system_table_t *) (unsigned long) systab;
> > > > + }
> > > > + if (efi_runtime_map) {
> > > > + memcpy(p, md, memmap.desc_size);
> > > > + p += memmap.desc_size;
> > > > + }
> > >
> > > Is this if () needed? Is it possible to enter the loop and have
> > > 'efi_runtime_map' be NULL?
> >
> > Yes, it is needed. if efi_runtime_map kmalloc fails I only print error, do not
> > return so kernel can still boot, just kexec on efi will not work that has been
> > put in the error message.
>
> OK. On second thought, is there any way to turn the above code into a
> call to efi_save_runtime_map()? Because you've basically duplicated that
> code and I can definitely envisage the two code paths fragmenting over
> time, e.g. when someone makes changes to one but not the other.
OK, will consider to reuse the function.
Thanks
Dave
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists