[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <52AD8E10.2010904@gmail.com>
Date: Sun, 15 Dec 2013 19:10:08 +0800
From: Jiang Liu <liuj97@...il.com>
To: Steven Rostedt <rostedt@...dmis.org>
CC: Catalin Marinas <catalin.marinas@....com>,
Will Deacon <will.deacon@....com>,
Sandeepa Prabhu <sandeepa.prabhu@...aro.org>,
AKASHI Takahiro <takahiro.akashi@...aro.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Hannes Frederic Sowa <hannes@...essinduktion.org>,
Andrew Jones <drjones@...hat.com>,
"David S. Miller" <davem@...emloft.net>,
Konrad Rzeszutek Wilk <konrad.wilk@...cle.com>,
linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
Jason Baron <jbaron@...mai.com>
Subject: Re: [PATCH v6 7/7] jump_label: use defined macros instead of hard-coding
for better readability
On 12/14/2013 12:20 AM, Steven Rostedt wrote:
> On Wed, 11 Dec 2013 00:03:53 +0800
> Jiang Liu <liuj97@...il.com> wrote:
>
>> Use macro JUMP_LABEL_TRUE_BRANCH instead of hard-coding for better
>> readability.
>
> Looks good, just a little nit. (see below)
>
>>
>> Signed-off-by: Jiang Liu <liuj97@...il.com>
>> ---
>> include/linux/jump_label.h | 15 ++++++++++-----
...
>> @@ -123,9 +126,11 @@ extern void static_key_slow_dec(struct static_key *key);
>> extern void jump_label_apply_nops(struct module *mod);
>>
>> #define STATIC_KEY_INIT_TRUE ((struct static_key) \
>> - { .enabled = ATOMIC_INIT(1), .entries = (void *)1 })
>> + { .enabled = ATOMIC_INIT(1), \
>> + .entries = (void *)JUMP_LABEL_TYPE_TRUE_BRANCH })
>> #define STATIC_KEY_INIT_FALSE ((struct static_key) \
>> - { .enabled = ATOMIC_INIT(0), .entries = (void *)0 })
>> + { .enabled = ATOMIC_INIT(0), \
>> + .entries = (void *)JUMP_LABEL_TYPE_FALSE_BRANCH })
>
> Can we prettify the backslashes like:
>
> #define STATIC_KEY_INIT_TRUE ((struct static_key) \
> { .enabled = ATOMIC_INIT(1), \
> .entries = (void *)JUMP_LABEL_TYPE_TRUE_BRANCH })
> #define STATIC_KEY_INIT_FALSE ((struct static_key) \
> { .enabled = ATOMIC_INIT(0), \
> .entries = (void *)JUMP_LABEL_TYPE_FALSE_BRANCH })
>
>
> Other than that.
>
> Acked-by: Steven Rostedt <rostedt@...dmis.org>
Thanks Steve.
Will make this change.
>
> -- Steve
>
>>
>> #else /* !HAVE_JUMP_LABEL */
>>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists