[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20131217104251.GA27274@gmail.com>
Date: Tue, 17 Dec 2013 11:42:51 +0100
From: Ingo Molnar <mingo@...nel.org>
To: Stephane Eranian <eranian@...gle.com>
Cc: linux-kernel@...r.kernel.org, peterz@...radead.org, mingo@...e.hu,
ak@...ux.intel.com, acme@...hat.com, jolsa@...hat.com,
zheng.z.yan@...el.com, bp@...en8.de, vincent.weaver@...ne.edu,
maria.n.dimakopoulou@...il.com
Subject: Re: [PATCH 2/2] perf/x86: add RAPL PP1 energy counter support
Nice patch!
I noticed a couple of small details:
* Stephane Eranian <eranian@...gle.com> wrote:
> Add support for the RAPL energy counter PP1.
>
> On client processors, it usually correspondss to the
s/correspondss
/corresponds
> energy consumption of the builtin graphic card.
>
> New event:
> - name: power/energy-gfx/
> - code: event=0x4
> - unit: 2^-32 Joules
>
> On processors without graphics, this should count 0.
> The patch only enables this event on client processors.
> EVENT_ATTR_STR(energy-cores, rapl_cores, "event=0x01");
> EVENT_ATTR_STR(energy-pkg , rapl_pkg, "event=0x02");
> EVENT_ATTR_STR(energy-ram , rapl_ram, "event=0x03");
> +EVENT_ATTR_STR(energy-gfx, rapl_gfx, "event=0x04");
> EVENT_ATTR_STR(energy-cores.unit, rapl_cores_unit, "Joules");
> EVENT_ATTR_STR(energy-pkg.unit , rapl_pkg_unit, "Joules");
> EVENT_ATTR_STR(energy-ram.unit , rapl_ram_unit, "Joules");
> +EVENT_ATTR_STR(energy-gfx.unit , rapl_gfx_unit, "Joules");
Nit: I think these fields have all similar lengths so they should be
vertically aligned, something like:
EVENT_ATTR_STR(energy-cores, rapl_cores, "event=0x01");
EVENT_ATTR_STR(energy-pkg , rapl_pkg , "event=0x02");
EVENT_ATTR_STR(energy-ram , rapl_ram , "event=0x03");
EVENT_ATTR_STR(energy-gfx , rapl_gfx , "event=0x04");
EVENT_ATTR_STR(energy-cores.unit, rapl_cores_unit, "Joules");
EVENT_ATTR_STR(energy-pkg.unit , rapl_pkg_unit , "Joules");
EVENT_ATTR_STR(energy-ram.unit , rapl_ram_unit , "Joules");
EVENT_ATTR_STR(energy-gfx.unit , rapl_gfx_unit , "Joules");
Also, instead of 'gfx', shouldn't it be 'gpu' throughout the patch?
Thanks,
Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists