lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 19 Dec 2013 10:16:14 +0100
From:	Michal Hocko <mhocko@...e.cz>
To:	Vladimir Davydov <vdavydov@...allels.com>
Cc:	linux-kernel@...r.kernel.org, linux-mm@...ck.org,
	cgroups@...r.kernel.org, devel@...nvz.org,
	Johannes Weiner <hannes@...xchg.org>,
	Glauber Costa <glommer@...il.com>,
	Christoph Lameter <cl@...ux.com>,
	Pekka Enberg <penberg@...nel.org>,
	Andrew Morton <akpm@...ux-foundation.org>
Subject: Re: [PATCH 1/6] slab: cleanup kmem_cache_create_memcg()

On Thu 19-12-13 12:51:38, Vladimir Davydov wrote:
> On 12/19/2013 12:44 PM, Michal Hocko wrote:
> > On Thu 19-12-13 10:31:43, Vladimir Davydov wrote:
> >> On 12/18/2013 08:56 PM, Michal Hocko wrote:
> >>> On Wed 18-12-13 17:16:52, Vladimir Davydov wrote:
> >>>> Signed-off-by: Vladimir Davydov <vdavydov@...allels.com>
> >>>> Cc: Michal Hocko <mhocko@...e.cz>
> >>>> Cc: Johannes Weiner <hannes@...xchg.org>
> >>>> Cc: Glauber Costa <glommer@...il.com>
> >>>> Cc: Christoph Lameter <cl@...ux.com>
> >>>> Cc: Pekka Enberg <penberg@...nel.org>
> >>>> Cc: Andrew Morton <akpm@...ux-foundation.org>
> >>> Dunno, is this really better to be worth the code churn?
> >>>
> >>> It even makes the generated code tiny bit bigger:
> >>> text    data     bss     dec     hex filename
> >>> 4355     171     236    4762    129a mm/slab_common.o.after
> >>> 4342     171     236    4749    128d mm/slab_common.o.before
> >>>
> >>> Or does it make the further changes much more easier? Be explicit in the
> >>> patch description if so.
> >> Hi, Michal
> >>
> >> IMO, undoing under labels looks better than inside conditionals, because
> >> we don't have to repeat the same deinitialization code then, like this
> >> (note three calls to kmem_cache_free()):
> > Agreed but the resulting code is far from doing nice undo on different
> > conditions. You have out_free_cache which frees everything regardless
> > whether name or cache registration failed. So it doesn't help with
> > readability much IMO.
> 
> AFAIK it's common practice not to split kfree's to be called under
> different labels on fail paths, because kfree(NULL) results in a no-op.
> Since on undo, we only call kfree, I introduce the only label. Of course
> I could do something like
> 
>     s->name=...
>     if (!s->name)
>         goto out_free_name;
>     err = __kmem_new_cache(...)
>     if (err)
>         goto out_free_name;
> <...>
> out_free_name:
>     kfree(s->name);
> out_free_cache:
>     kfree(s);
>     goto out_unlock;
> 
> But I think using only out_free_cache makes the code look clearer.

I disagree. It is much easier to review code for mem leaks when you have
explicit cleanup gotos. But this is a matter of taste I guess.
-- 
Michal Hocko
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ