[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20131219091903.GF9331@dhcp22.suse.cz>
Date: Thu, 19 Dec 2013 10:19:03 +0100
From: Michal Hocko <mhocko@...e.cz>
To: Vladimir Davydov <vdavydov@...allels.com>
Cc: linux-kernel@...r.kernel.org, linux-mm@...ck.org,
cgroups@...r.kernel.org, devel@...nvz.org,
Johannes Weiner <hannes@...xchg.org>,
Glauber Costa <glommer@...il.com>,
Christoph Lameter <cl@...ux.com>,
Pekka Enberg <penberg@...nel.org>,
Andrew Morton <akpm@...ux-foundation.org>
Subject: Re: [PATCH 2/6] memcg, slab: kmem_cache_create_memcg(): free memcg
params on error
On Thu 19-12-13 13:01:28, Vladimir Davydov wrote:
> On 12/19/2013 12:48 PM, Michal Hocko wrote:
> > On Thu 19-12-13 10:32:29, Vladimir Davydov wrote:
> >> On 12/18/2013 09:06 PM, Michal Hocko wrote:
> >>> On Wed 18-12-13 17:16:53, Vladimir Davydov wrote:
> >>>> Plus, rename memcg_register_cache() to memcg_init_cache_params(),
> >>>> because it actually does not register the cache anywhere, but simply
> >>>> initialize kmem_cache::memcg_params.
> >>> I've almost missed this is a memory leak fix.
> >> Yeah, the comment is poor, sorry about that. Will fix it.
> >>
> >>> I do not mind renaming and the name but wouldn't
> >>> memcg_alloc_cache_params suit better?
> >> As you wish. I don't have a strong preference for memcg_init_cache_params.
> > I really hate naming... but it seems that alloc is a better fit. _init_
> > would expect an already allocated object.
> >
> > Btw. memcg_free_cache_params is called only once which sounds
> > suspicious. The regular destroy path should use it as well?
> > [...]
>
> The usual destroy path uses memcg_release_cache(), which does the trick.
> Plus, it actually "unregisters" the cache. BTW, I forgot to substitute
> kfree(s->memcg_params) with the new memcg_free_cache_params() there.
> Although it currently does not break anything, better to fix it in case
> new memcg_free_cache_params() will have to do something else.
>
> And you're right about the naming is not good.
>
> Currently we have:
>
> on create:
> memcg_register_cache()
> memcg_cache_list_add()
> on destroy:
> memcg_release_cache()
>
> After this patch we would have:
>
> on create:
> memcg_alloc_cache_params()
> memcg_register_cache()
> on destroy:
> memcg_release_cache()
>
> Still not perfect: "alloc" does not have corresponding "free", while
> "register" does not have corresponding "unregister", everything is done
> by "release".
>
> What do you think about splitting memcg_release_cache() into two functions:
>
> memcg_unregister_cache()
> memcg_free_cache_params()
yes I am all for cleaning up this mess. I am still trying to wrap my
head around what is each of this function responsible for.
Absolute lack of documentation is not helping at all...
>
> ?
>
> Thanks.
--
Michal Hocko
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists