lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 20 Dec 2013 10:05:17 +0900
From:	Namhyung Kim <namhyung@...nel.org>
To:	Steven Rostedt <rostedt@...dmis.org>
Cc:	Oleg Nesterov <oleg@...hat.com>,
	Masami Hiramatsu <masami.hiramatsu.pt@...achi.com>,
	Srikar Dronamraju <srikar@...ux.vnet.ibm.com>,
	Hyeoncheol Lee <cheol.lee@....com>,
	"zhangwei\(Jovi\)" <jovi.zhangwei@...wei.com>,
	Arnaldo Carvalho de Melo <acme@...stprotocols.net>,
	Hemant Kumar <hkshaw@...ux.vnet.ibm.com>,
	LKML <linux-kernel@...r.kernel.org>,
	Namhyung Kim <namhyung.kim@....com>
Subject: Re: [PATCH 10/17] tracing/probes: Move 'symbol' fetch method to kprobes

Hi Steve,

On Thu, 19 Dec 2013 09:18:30 -0500, Steven Rostedt wrote:
> On Thu, 19 Dec 2013 16:34:09 +0900
> Namhyung Kim <namhyung@...nel.org> wrote:
>
>> Hi Steve,
>> 
>> On Wed, 18 Dec 2013 15:23:38 -0500, Steven Rostedt wrote:
>> > On Mon, 16 Dec 2013 13:32:09 +0900
>> > Namhyung Kim <namhyung@...nel.org> wrote:
>> >
>> >> index 5395d37e5e72..adc9ac70fd3c 100644
>> >> --- a/kernel/trace/trace_uprobe.c
>> >> +++ b/kernel/trace/trace_uprobe.c
>> >> @@ -115,6 +115,14 @@ DEFINE_BASIC_FETCH_FUNCS(stack)
>> >>  #define fetch_stack_string_size	NULL
>> >>  
>> >>  
>> >> +/* uprobes don't support symbol fetch methods */
>> >
>> > "uprobes does not support symbol fetch methods"
>> 
>> I was confused since the "uprobes" looks like a plural..
>> 
>
> Heh, yeah I guess it can be. I was thinking of it as singular. I was
> thinking of ftrace, perf, kprobes, uprobes, all being the same. As in
> "kprobes system" or "uprobes system". I implicitly added in my mind
> "system" to that sentence.
>
>  uprobes (system) does not support fetch methods
>
> But I guess one can think of it as each individual uprobe does not
> support fetch methods, so "uprobes do not support fetch methods" would
> then be correct.
>
> But still, I would use the full "do not" as the "don't" here just
> sounds funny to me (sounds like a boxer talking "Dey don't do dat to
> me! Dey don't support fetch methods either!")

Okay, will use "do not" in the next version (if needed :) ).

Thanks,
Namhyung
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists