[<prev] [next>] [day] [month] [year] [list]
Message-Id: <1389180364-4844-1-git-send-email-stefan.kristiansson@saunalahti.fi>
Date: Wed, 8 Jan 2014 13:26:04 +0200
From: Stefan Kristiansson <stefan.kristiansson@...nalahti.fi>
To: linux-kernel@...r.kernel.org, linux@...ts.openrisc.net
Cc: jonas@...thpole.se,
Stefan Kristiansson <stefan.kristiansson@...nalahti.fi>
Subject: [PATCH] openrisc: head: use THREAD_SIZE instead of magic constant
Signed-off-by: Stefan Kristiansson <stefan.kristiansson@...nalahti.fi>
---
arch/openrisc/kernel/head.S | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/arch/openrisc/kernel/head.S b/arch/openrisc/kernel/head.S
index eecc8df..0c21acd 100644
--- a/arch/openrisc/kernel/head.S
+++ b/arch/openrisc/kernel/head.S
@@ -24,6 +24,7 @@
#include <asm/page.h>
#include <asm/mmu.h>
#include <asm/pgtable.h>
+#include <asm/thread_info.h>
#include <asm/cache.h>
#include <asm/spr_defs.h>
#include <asm/asm-offsets.h>
@@ -486,7 +487,8 @@ _start:
/*
* set up initial ksp and current
*/
- LOAD_SYMBOL_2_GPR(r1,init_thread_union+0x2000) // setup kernel stack
+ /* setup kernel stack */
+ LOAD_SYMBOL_2_GPR(r1,init_thread_union + THREAD_SIZE)
LOAD_SYMBOL_2_GPR(r10,init_thread_union) // setup current
tophys (r31,r10)
l.sw TI_KSP(r31), r1
--
1.8.3.2
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists