[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20140112114717.GA31318@amd.pavel.ucw.cz>
Date: Sun, 12 Jan 2014 12:47:17 +0100
From: Pavel Machek <pavel@....cz>
To: Tomasz Figa <tomasz.figa@...il.com>
Cc: linux-pm@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-samsung-soc@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org, devicetree@...r.kernel.org,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
"Rafael J. Wysocki" <rjw@...ysocki.net>,
Len Brown <len.brown@...el.com>,
Russell King <linux@....linux.org.uk>,
Kukjin Kim <kgene.kim@...sung.com>,
Kumar Gala <galak@...eaurora.org>,
Ian Campbell <ijc+devicetree@...lion.org.uk>,
Mark Rutland <mark.rutland@....com>,
Pawel Moll <pawel.moll@....com>,
Rob Herring <robh+dt@...nel.org>,
Bartlomiej Zolnierkiewicz <b.zolnierkie@...sung.com>,
Stephen Warren <swarren@...dotorg.org>,
Tomasz Figa <t.figa@...sung.com>
Subject: Re: [PATCH RFC 01/10] ARM: s3c64xx: pm: Use name field of
generic_pm_domain
On Sat 2014-01-11 20:42:43, Tomasz Figa wrote:
> This patch removes name field from private s3c64xx_pm_domain struct and
> moves domain name to dedicated field of generic_pm_domain struct.
>
> When at it, beautify the names a bit, since they are used by genpd core
> as message prefixes.
>
> Signed-off-by: Tomasz Figa <tomasz.figa@...il.com>
> ---
> arch/arm/mach-s3c64xx/pm.c | 19 +++++++++----------
> 1 file changed, 9 insertions(+), 10 deletions(-)
>
> diff --git a/arch/arm/mach-s3c64xx/pm.c b/arch/arm/mach-s3c64xx/pm.c
> index 8cdb824..5238d66 100644
> --- a/arch/arm/mach-s3c64xx/pm.c
> +++ b/arch/arm/mach-s3c64xx/pm.c
> @@ -35,7 +35,6 @@
> #include "regs-syscon-power.h"
>
> struct s3c64xx_pm_domain {
> - char *const name;
> u32 ena;
> u32 pwr_stat;
> struct generic_pm_domain pd;
> @@ -76,7 +75,7 @@ static int s3c64xx_pd_on(struct generic_pm_domain *domain)
> } while (retry--);
>
> if (!retry) {
> - pr_err("Failed to start domain %s\n", pd->name);
> + pr_err("Failed to start domain %s\n", pd->pd.name);
> return -EBUSY;
> }
So you changed text "failed to start domain I" to "failed to start
domain domain_i". Not sure that's an improvement...?
Could we get some more descriptive names for the domains?
> static struct s3c64xx_pm_domain s3c64xx_pm_i = {
> - .name = "I",
> .ena = S3C64XX_NORMALCFG_DOMAIN_I_ON,
> .pwr_stat = S3C64XX_BLKPWRSTAT_I,
> .pd = {
> + .name = "domain_i",
> .power_off = s3c64xx_pd_off,
> .power_on = s3c64xx_pd_on,
> },
> };
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists