lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CANq1E4SFdvV0OCtd4bg6OX9wq0ZhF5fxG-eLj9XWByLsnJvMuw@mail.gmail.com>
Date:	Wed, 12 Feb 2014 11:17:20 +0100
From:	David Herrmann <dh.herrmann@...il.com>
To:	Benjamin Tissoires <benjamin.tissoires@...hat.com>
Cc:	Benjamin Tissoires <benjamin.tissoires@...il.com>,
	Jiri Kosina <jkosina@...e.cz>,
	"open list:HID CORE LAYER" <linux-input@...r.kernel.org>,
	linux-kernel <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 01/14] HID: uHID: remove duplicated code

Hi

On Mon, Feb 10, 2014 at 6:58 PM, Benjamin Tissoires
<benjamin.tissoires@...hat.com> wrote:
> uhid_hid_output_report() can be implemented through a simple call
> to uhid_hid_output_raw().
>
> Signed-off-by: Benjamin Tissoires <benjamin.tissoires@...hat.com>
> ---
>  drivers/hid/uhid.c | 22 +---------------------
>  1 file changed, 1 insertion(+), 21 deletions(-)
>
> diff --git a/drivers/hid/uhid.c b/drivers/hid/uhid.c
> index 12439e1..b6de903 100644
> --- a/drivers/hid/uhid.c
> +++ b/drivers/hid/uhid.c
> @@ -247,27 +247,7 @@ static int uhid_hid_output_raw(struct hid_device *hid, __u8 *buf, size_t count,
>  static int uhid_hid_output_report(struct hid_device *hid, __u8 *buf,
>                                   size_t count)
>  {
> -       struct uhid_device *uhid = hid->driver_data;
> -       unsigned long flags;
> -       struct uhid_event *ev;
> -
> -       if (count < 1 || count > UHID_DATA_MAX)
> -               return -EINVAL;
> -
> -       ev = kzalloc(sizeof(*ev), GFP_KERNEL);
> -       if (!ev)
> -               return -ENOMEM;
> -
> -       ev->type = UHID_OUTPUT;
> -       ev->u.output.size = count;
> -       ev->u.output.rtype = UHID_OUTPUT_REPORT;
> -       memcpy(ev->u.output.data, buf, count);
> -
> -       spin_lock_irqsave(&uhid->qlock, flags);
> -       uhid_queue(uhid, ev);
> -       spin_unlock_irqrestore(&uhid->qlock, flags);
> -
> -       return count;
> +       return uhid_hid_output_raw(hid, buf, count, HID_OUTPUT_REPORT);

Took me a while to see that we have:
  HID_OUTPUT_REPORT
  UHID_OUTPUT_REPORT
.. gnah! I should have named the uhid stuff better.. anyhow, patch looks good:

Reviewed-by: David Herrmann <dh.herrmann@...il.com>

Thanks
David

>  }
>
>  static struct hid_ll_driver uhid_hid_driver = {
> --
> 1.8.3.1
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ