lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 19 Feb 2014 13:46:39 +0800
From:	Jiang Liu <jiang.liu@...ux.intel.com>
To:	"Rafael J. Wysocki" <rjw@...ysocki.net>
CC:	"Rafael J . Wysocki" <rafael.j.wysocki@...el.com>,
	Lv Zheng <lv.zheng@...el.com>, Len Brown <lenb@...nel.org>,
	Robert Moore <robert.moore@...el.com>,
	Tony Luck <tony.luck@...el.com>, linux-acpi@...r.kernel.org,
	linux-kernel@...r.kernel.org, devel@...ica.org
Subject: Re: [RFC Patch v1 2/6] ACPI: rename acpi_evaluate_hotplug_ost to
 acpi_evaluate_ost for reuse

Hi Rafael,
	We have following code to deal with existing users.
+#ifdef ACPI_HOTPLUG_OST
+#define	acpi_evaluate_hotplug_ost	acpi_evaluate_ost
+#else
+static inline acpi_status
 acpi_evaluate_hotplug_ost(acpi_handle handle, u32 source_event,
-			u32 status_code, struct acpi_buffer *status_buf);
+			u32 status_code, struct acpi_buffer *status_buf)
+{ return AE_OK; }
+#endif

Thanks!

On 2014/2/18 9:06, Rafael J. Wysocki wrote:
> On Monday, February 17, 2014 01:02:49 PM Jiang Liu wrote:
>> Rename acpi_evaluate_hotplug_ost() to acpi_evaluate_ost() for later resue.
>>
>> Signed-off-by: Jiang Liu <jiang.liu@...ux.intel.com>
>> ---
>>  drivers/acpi/utils.c    |   14 ++++----------
>>  include/acpi/acpi_bus.h |   10 +++++++++-
>>  2 files changed, 13 insertions(+), 11 deletions(-)
>>
>> diff --git a/drivers/acpi/utils.c b/drivers/acpi/utils.c
>> index 85e3b61..19d0169 100644
>> --- a/drivers/acpi/utils.c
>> +++ b/drivers/acpi/utils.c
>> @@ -433,17 +433,15 @@ EXPORT_SYMBOL(acpi_get_physical_device_location);
>>   * When the platform does not support _OST, this function has no effect.
>>   */
>>  acpi_status
>> -acpi_evaluate_hotplug_ost(acpi_handle handle, u32 source_event,
>> -		u32 status_code, struct acpi_buffer *status_buf)
> 
> There are users of this, what about updating them?
> 
>> +acpi_evaluate_ost(acpi_handle handle, u32 source_event, u32 status_code,
>> +		  struct acpi_buffer *status_buf)
>>  {
>> -#ifdef ACPI_HOTPLUG_OST
>>  	union acpi_object params[3] = {
>>  		{.type = ACPI_TYPE_INTEGER,},
>>  		{.type = ACPI_TYPE_INTEGER,},
>>  		{.type = ACPI_TYPE_BUFFER,}
>>  	};
>>  	struct acpi_object_list arg_list = {3, params};
>> -	acpi_status status;
>>  
>>  	params[0].integer.value = source_event;
>>  	params[1].integer.value = status_code;
>> @@ -455,13 +453,9 @@ acpi_evaluate_hotplug_ost(acpi_handle handle, u32 source_event,
>>  		params[2].buffer.length = 0;
>>  	}
>>  
>> -	status = acpi_evaluate_object(handle, "_OST", &arg_list, NULL);
>> -	return status;
>> -#else
>> -	return AE_OK;
>> -#endif
>> +	return acpi_evaluate_object(handle, "_OST", &arg_list, NULL);
>>  }
>> -EXPORT_SYMBOL(acpi_evaluate_hotplug_ost);
>> +EXPORT_SYMBOL(acpi_evaluate_ost);
>>  
>>  /**
>>   * acpi_handle_printk: Print message with ACPI prefix and object path
>> diff --git a/include/acpi/acpi_bus.h b/include/acpi/acpi_bus.h
>> index 8256eb4..adef502 100644
>> --- a/include/acpi/acpi_bus.h
>> +++ b/include/acpi/acpi_bus.h
>> @@ -49,8 +49,16 @@ acpi_evaluate_reference(acpi_handle handle,
>>  			struct acpi_object_list *arguments,
>>  			struct acpi_handle_list *list);
>>  acpi_status
>> +acpi_evaluate_ost(acpi_handle handle, u32 source_event, u32 status_code,
>> +		  struct acpi_buffer *status_buf);
>> +#ifdef ACPI_HOTPLUG_OST
>> +#define	acpi_evaluate_hotplug_ost	acpi_evaluate_ost
>> +#else
>> +static inline acpi_status
>>  acpi_evaluate_hotplug_ost(acpi_handle handle, u32 source_event,
>> -			u32 status_code, struct acpi_buffer *status_buf);
>> +			u32 status_code, struct acpi_buffer *status_buf)
>> +{ return AE_OK; }
>> +#endif
>>  
>>  acpi_status
>>  acpi_get_physical_device_location(acpi_handle handle, struct acpi_pld_info **pld);
>>
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ