lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Sun, 23 Feb 2014 08:48:46 -0800
From:	"Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>
To:	josh@...htriplett.org
Cc:	linux-kernel@...r.kernel.org, mingo@...nel.org,
	laijs@...fujitsu.com, dipankar@...ibm.com,
	akpm@...ux-foundation.org, mathieu.desnoyers@...icios.com,
	niv@...ibm.com, tglx@...utronix.de, peterz@...radead.org,
	rostedt@...dmis.org, dhowells@...hat.com, edumazet@...gle.com,
	darren@...art.com, fweisbec@...il.com, oleg@...hat.com, sbw@....edu
Subject: Re: [PATCH tip/core/rcu 17/55] rcutorture: Abstract torture_param()

On Tue, Feb 18, 2014 at 03:53:40PM -0800, josh@...htriplett.org wrote:
> On Tue, Feb 18, 2014 at 01:31:47PM -0800, Paul E. McKenney wrote:
> > On Mon, Feb 17, 2014 at 04:23:01PM -0800, Josh Triplett wrote:
> > > On Mon, Feb 17, 2014 at 02:12:21PM -0800, Paul E. McKenney wrote:
> > > > From: "Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>
> > > > 
> > > > Create a torture_param() macro and apply it to rcutorture in order to
> > > > save a few lines of code.  This same macro may be applied to other
> > > > torture frameworks.
> > > > 
> > > > Signed-off-by: Paul E. McKenney <paulmck@...ux.vnet.ibm.com>
> > > 
> > > Your commit message says "torture_param", but your code says
> > > "torture_parm".  Let's go with the former, please; no need to creat more
> > > disemvoweled abbreviations.
> > 
> > Gd pnt, fxd s sggstd.
> 
> Thnks!
> 
> > > Also, this seems rather generally useful.  A quick check with "git grep
> > > -B2 MODULE_PARM_DESC" turns up numerous instances of the pattern.  You
> > > might consider adding this as a helper DECLARE_MODULE_PARAM_RO in
> > > include/linux/moduleparam.h (possibly calling a generalized version that
> > > takes the mode as another parameter).
> > 
> > Added to the todo list.  Another parameter is static vs. not -- I only
> > had one non-static instance, which I left open-coded.
> 
> I debated that one.  You could leave out the "static" and just write
> "static DECLARE_MODULE_PARAM_RO", but given that you almost always
> *want* static for a module parameter...

Indeed, adding a storage-class argument for the benefit of only one
parameter didn't seem to make sense.

							Thanx, Paul

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists