[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20140228100816.GA13406@amd.pavel.ucw.cz>
Date: Fri, 28 Feb 2014 11:08:16 +0100
From: Pavel Machek <pavel@....cz>
To: Jenny Tc <jenny.tc@...el.com>
Cc: Linus Walleij <linus.walleij@...aro.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
Dmitry Eremin-Solenikov <dbaryshkov@...il.com>,
Anton Vorontsov <cbouatmailru@...il.com>,
Anton Vorontsov <anton.vorontsov@...aro.org>,
Kim Milo <Milo.Kim@...com>, Lee Jones <lee.jones@...aro.org>,
Jingoo Han <jg1.han@...sung.com>,
Chanwoo Choi <cw00.choi@...sung.com>,
Sachin Kamat <sachin.kamat@...aro.org>,
Lars-Peter Clausen <lars@...afoo.de>,
Pali Rohár <pali.rohar@...il.com>,
Rhyland Klein <rklein@...dia.com>,
"Rafael J. Wysocki" <rjw@...ysocki.net>,
David Woodhouse <dwmw2@...radead.org>,
Tony Lindgren <tony@...mide.com>,
Russell King <linux@....linux.org.uk>,
Sebastian Reichel <sre@...g0.de>,
Aaro Koskinen <aaro.koskinen@....fi>,
Pallala Ramakrishna <ramakrishna.pallala@...el.com>,
Ивайло Димитров
<freemangordon@....bg>, Linux-OMAP <linux-omap@...r.kernel.org>
Subject: Re: [PATCH 3/4] power_supply: Introduce PSE compliant algorithm
On Fri 2014-02-28 08:37:27, Jenny Tc wrote:
> On Thu, Feb 27, 2014 at 09:18:57PM +0100, Linus Walleij wrote:
> > On Tue, Feb 4, 2014 at 6:12 AM, Jenny TC <jenny.tc@...el.com> wrote:
> >
> > > +static inline bool __is_battery_full
> > > + (long volt, long cur, long iterm, unsigned long cv)
> >
> > Overall I wonder if you've run checkpatch on these patches, but why
> > are you naming this one function with a double __underscore?
> > Just is_battery_full_check() or something would work fine I guess?
>
> Just to convey that is_battery_full is a local function and not generic. You
> can find similar usage in power_supply_core.c (__power_supply_changed_work)
> and in other drivers. Isn't it advised to have __ prefixes?
It is static; everybody sees it is local. __ prefix usually means
something else.
> > > + u16 capacity; /* mAh */
> > > + u16 voltage_max; /* mV */
> > > + /* charge termination current */
> > > + u16 chrg_term_mA;
> > > + /* Low battery level voltage */
> > > + u16 low_batt_mV;
> > > + /* upper and lower temperature limits on discharging */
> > > + s8 disch_temp_ul; /* Degree Celsius */
> > > + s8 disch_temp_ll; /* Degree Celsius */
> > > + /* number of temperature monitoring ranges */
> > > + u16 temp_mon_ranges;
> > > + struct psy_ps_temp_chg_table temp_mon_range[BATT_TEMP_NR_RNG];
> > > + /* lowest temperature supported */
> > > + s8 temp_low_lim;
> > > +} __packed;
> >
> > Why packed, and convert to kerneldoc for this struct.
>
> Battery charging profile, may come from EEPROM/emmc which would be packed.
Do you need to do endianness conversion, too?
Pavel
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists