[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87lhwvawc4.fsf@tassilo.jf.intel.com>
Date: Fri, 28 Feb 2014 11:08:59 -0800
From: Andi Kleen <andi@...stfloor.org>
To: Don Zickus <dzickus@...hat.com>
Cc: acme@...stprotocols.net, LKML <linux-kernel@...r.kernel.org>,
jolsa@...hat.com, jmario@...hat.com, fowles@...each.com,
eranian@...gle.com, Arnaldo Carvalho de Melo <acme@...hat.com>,
David Ahern <dsahern@...il.com>,
Frederic Weisbecker <fweisbec@...il.com>,
Mike Galbraith <efault@....de>,
Paul Mackerras <paulus@...ba.org>,
Peter Zijlstra <peterz@...radead.org>,
Richard Fowles <rfowles@...hat.com>
Subject: Re: [PATCH 08/19] perf c2c: Shared data analyser
Don Zickus <dzickus@...hat.com> writes:
> +
> +static const struct perf_evsel_str_handler handlers[] = {
> + { "cpu/mem-loads,ldlat=30/pp", perf_c2c__process_load, },
> + { "cpu/mem-stores/pp", perf_c2c__process_store, },
The 30 magic number should probably be configurable.
Using load-latency here rules out Atom, so at some point
you would need to get rid of that.
I suspect on most systems you should rather use p
instead of pp to get the overhead down (before Haswell pp
is expensive)
> +static int perf_c2c__record(int argc, const char **argv)
> +{
> + unsigned int rec_argc, i, j;
> + const char **rec_argv;
> + const char * const record_args[] = {
> + "record",
> + /* "--phys-addr", */
So is that needed or not?
-Andi
--
ak@...ux.intel.com -- Speaking for myself only
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists