[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1393956248-9354-1-git-send-email-doug.lkml@gmail.com>
Date: Tue, 4 Mar 2014 23:34:08 +0530
From: Doug <doug.lkml@...il.com>
To: sparclinux@...r.kernel.org
Cc: linux-kernel@...r.kernel.org, Doug <doug.lkml@...il.com>
Subject: [PATCH 1/1] sparc64:tsb.c:use array size macro rather than number
This is a small patch which uses ARRAY_SIZE macro
rather than a number to make code readability better.
Signed-off-by: Doug <doug.lkml@...il.com>
---
arch/sparc/mm/tsb.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/sparc/mm/tsb.c b/arch/sparc/mm/tsb.c
index 3b3a360..f5d506f 100644
--- a/arch/sparc/mm/tsb.c
+++ b/arch/sparc/mm/tsb.c
@@ -273,7 +273,7 @@ void __init pgtable_cache_init(void)
prom_halt();
}
- for (i = 0; i < 8; i++) {
+ for (i = 0; i < ARRAY_SIZE(tsb_cache_names); i++) {
unsigned long size = 8192 << i;
const char *name = tsb_cache_names[i];
--
1.8.1.2
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists