[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5358F2A1.40106@cogentembedded.com>
Date: Thu, 24 Apr 2014 15:16:49 +0400
From: Sergei Shtylyov <sergei.shtylyov@...entembedded.com>
To: Geert Uytterhoeven <geert+renesas@...der.be>,
"Rafael J. Wysocki" <rjw@...ysocki.net>, linux-pm@...r.kernel.org,
linux-kernel@...r.kernel.org
CC: Ben Dooks <ben.dooks@...ethink.co.uk>,
linux-arm-kernel@...ts.infradead.org, linux-omap@...r.kernel.org,
linux-sh@...r.kernel.org, devicetree@...r.kernel.org
Subject: Re: [PATCH 1/6] PM / clock_ops: Add helpers combining generic runtime
and generic clock PM
Hello.
On 24-04-2014 14:26, Geert Uytterhoeven wrote:
> Add helpers pm_generic_runtime_clk_suspend() and
> pm_generic_clk_runtime_resume(), combining generic runtime PM and generic
> clock PM.
> Signed-off-by: Geert Uytterhoeven <geert+renesas@...der.be>
[...]
> diff --git a/include/linux/pm_clock.h b/include/linux/pm_clock.h
> index 6981aa288c45..bf1e4d09a0ca 100644
> --- a/include/linux/pm_clock.h
> +++ b/include/linux/pm_clock.h
> @@ -35,6 +35,8 @@ extern int pm_clk_add_clk(struct device *dev, struct clk *clk);
> extern void pm_clk_remove(struct device *dev, const char *con_id);
> extern int pm_clk_suspend(struct device *dev);
> extern int pm_clk_resume(struct device *dev);
> +extern int pm_generic_runtime_clk_suspend(struct device *dev);
> +extern int pm_generic_clk_runtime_resume(struct device *dev);
Shouldn't these function names be symmetric? I think '_clk' and '_runtime'
need swapping in one case.
WBR, Sergei
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists