[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <1398571754-12443-1-git-send-email-laijs@cn.fujitsu.com>
Date: Sun, 27 Apr 2014 12:08:55 +0800
From: Lai Jiangshan <laijs@...fujitsu.com>
To: <linux-kernel@...r.kernel.org>
CC: Tejun Heo <tj@...nel.org>, Lai Jiangshan <laijs@...fujitsu.com>
Subject: [PATCH 00/10] workqueue: async worker destruction and pool-binding synchronization
Patch1-4: async worker destruction
The old version(https://lkml.org/lkml/2014/2/17/418) code of async worker
destruction has to dance with pool->lock and worker_idr, it is complicated.
But worker_idr in the new version dosn't requies pool->lock, and the code in
put_unbound_pool() which waits workers exit is changed to wait on a
wait_queue_head_t. These two changes make the new async worker destruction
much simpler.
Patch2 reduces the review burden. It will be easier to review the whole
patchset if we know destroy_worker() is forced to destroy idle workers only.
==========
Patch5-10: pool-binding synchronization and simplify the workers management
The code which binds a worker to the pool and unbind a worker from the pool
is unfolded in create_worker()/destroy_worker().
The patchset moves this pool-binding code out and wraps them.
patch3-4 moves the pool-unbinding code out from destroy_worker(), and make
manger_mutex only protects the pool-unbinding code only rather than
protects the whole worker-destruction path.
patch5-7 makes manger_mutex only protects the pool-binding code rather than the
whole worker-creation path.
patch8: rename manger_mutex to bind_mutex
patch9-10: moves the pool-binding code out from create_worker() and use it for
rescuer.
Lai Jiangshan (10):
workqueue: use manager lock only to protect worker_idr
workqueue: destroy_worker() should destroy idle workers only
workqueue: async worker destruction
workqueue: destroy worker directly in the idle timeout handler
workqueue: separate iteration role from worker_idr
workqueue: convert worker_idr to worker_ida
workqueue: narrow the protection range of manager_mutex
workqueue: rename manager_mutex to bind_mutex
workqueue: separate pool-binding code out from create_worker()
workqueue: use generic pool-bind/unbind routine for rescuers
kernel/workqueue.c | 396 +++++++++++++------------------------------
kernel/workqueue_internal.h | 1 +
2 files changed, 120 insertions(+), 277 deletions(-)
--
1.7.4.4
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists