[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAKohpo=3_7G+3bMF2CpWgZXvktdXBkCi4-tCxogwGcvvEEh18w@mail.gmail.com>
Date: Wed, 7 May 2014 10:53:16 +0530
From: Viresh Kumar <viresh.kumar@...aro.org>
To: Stratos Karafotis <stratosk@...aphore.gr>
Cc: Geert Uytterhoeven <geert@...ux-m68k.org>,
"Rafael J. Wysocki" <rjw@...ysocki.net>,
Jesper Nilsson <jesper.nilsson@...s.com>,
Hans-Christian Egtvedt <egtvedt@...fundet.no>,
Dirk Brandewie <dirk.j.brandewie@...el.com>,
"linux-doc@...r.kernel.org" <linux-doc@...r.kernel.org>,
"cpufreq@...r.kernel.org" <cpufreq@...r.kernel.org>,
"linux-pm@...r.kernel.org" <linux-pm@...r.kernel.org>,
LKML <linux-kernel@...r.kernel.org>,
Randy Dunlap <rdunlap@...radead.org>,
"David S. Miller" <davem@...emloft.net>,
Linus Walleij <linus.walleij@...aro.org>,
Simon Horman <horms@...ge.net.au>,
Sekhar Nori <nsekhar@...com>, Samuel Ortiz <samuel@...tiz.org>,
Linux-sh list <linux-sh@...r.kernel.org>
Subject: Re: [PATCH v5 0/8] Introduce new cpufreq helper macros
On 6 May 2014 23:25, Stratos Karafotis <stratosk@...aphore.gr> wrote:
> My bad. I'm sorry for this. :(
>
> Rafael,
> A solution could be to make cpufreq_next_valid an inline function in cpufreq.h,
> but as Viresh mentioned this would be very inefficient because of multiple copies.
That statement was true when we didn't had this problem..
> So, maybe it's better to revert the 2 patches that don't depend on CONFIG_CPU_FREQ:
>
> 4229e1c61a4a ("sh: clk: Use cpufreq_for_each_valid_entry macro for iteration") and
> 04ae58645afa ("irda: sh_sir: Use cpufreq_for_each_valid_entry macro for iteration").
This doesn't look right. It can happen to some other drivers as well in future.
So, there are two solutions I can think of:
1. move cpufreq_next_valid and rename it to __cpufreq_next_valid(). Also make it
inline. Then create two versions of cpufreq_next_valid(), one inlined (only when
CONFIG_CPU_FREQ=n) and other one in cpufreq.c (non- inlined)..
But probably that would be called ugly by some people :)
2. Make cpufreq_next_valid() inline and forget about extra space it takes :)
@Rafel: Let me know which one you like :)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists